aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-11-06 12:48:49 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-11-06 12:49:40 +0200
commitbd3d7c8587c6a229fdf242bfd12d540e5aa8acd3 (patch)
treeb723120ff48e65ca27949275a3596d6301c9c7bb /gnu
parent683e3f4fabdb431804d40c9cc7bd59240cc7d537 (diff)
downloadguix-bd3d7c8587c6a229fdf242bfd12d540e5aa8acd3.tar.gz
guix-bd3d7c8587c6a229fdf242bfd12d540e5aa8acd3.zip
gnu: xlsx2csv: Honor the #:tests? flag.
* gnu/packages/xml.scm (xlsx2csv)[arguments]: Adjust the custom 'check phase to honor the #:tests? flag. Change-Id: I13809dd414bc0e27b5bf404c35dabf67bbc4c4f4
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xml.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index ef084f607b..181b90ae24 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1458,12 +1458,13 @@ elements to their parents
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
+ (lambda* (#:key tests? #:allow-other-keys)
(substitute* "test/run"
;; Run tests with `python' only.
(("^(PYTHON_VERSIONS = ).*" all m)
(string-append m "['']")))
- (invoke "test/run"))))))
+ (when tests?
+ (invoke "test/run")))))))
(home-page "https://github.com/dilshod/xlsx2csv")
(synopsis "XLSX to CSV converter")
(description