aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-11-06 12:46:25 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-11-06 12:49:40 +0200
commit683e3f4fabdb431804d40c9cc7bd59240cc7d537 (patch)
tree0f039d1820641b9d2333a63cf1f6c2940be61d6e /gnu
parentff799a1a956a3cf636774701f632c779d08589bf (diff)
downloadguix-683e3f4fabdb431804d40c9cc7bd59240cc7d537.tar.gz
guix-683e3f4fabdb431804d40c9cc7bd59240cc7d537.zip
gnu: tinyxml: Fix cross-compiling.
* gnu/packages/xml.scm (tinyxml)[arguments]: Adjust the custom 'build-shared-library phase to use the correct compiler for the target. Change-Id: I7db740fca974aa719e06fab4d67cee1a3e014312
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xml.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 575cc016bb..ef084f607b 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1278,7 +1278,7 @@ UTF-8 and UTF-16 encoding.")
(delete 'configure)
(add-after 'build 'build-shared-library
(lambda _
- (invoke "g++" "-Wall" "-O2" "-shared" "-fpic"
+ (invoke ,(cxx-for-target) "-Wall" "-O2" "-shared" "-fpic"
"tinyxml.cpp" "tinyxmlerror.cpp"
"tinyxmlparser.cpp" "tinystr.cpp"
"-o" "libtinyxml.so")))