aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xml.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index ef084f607b..181b90ae24 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1458,12 +1458,13 @@ elements to their parents
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
+ (lambda* (#:key tests? #:allow-other-keys)
(substitute* "test/run"
;; Run tests with `python' only.
(("^(PYTHON_VERSIONS = ).*" all m)
(string-append m "['']")))
- (invoke "test/run"))))))
+ (when tests?
+ (invoke "test/run")))))))
(home-page "https://github.com/dilshod/xlsx2csv")
(synopsis "XLSX to CSV converter")
(description