aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorWojtek Kosior <koszko@koszko.org>2022-04-22 16:43:11 +0200
committerWojtek Kosior <koszko@koszko.org>2022-04-25 13:19:02 +0200
commit4d8810538798aa815a459f298349a03fc6b3ea3f (patch)
tree913f7eb355cde988c621b16928349e3623fb19f1 /pyproject.toml
parentbfd6005d0e1481e8a4df1f06c74e70a558199b71 (diff)
downloadhaketilo-hydrilla-4d8810538798aa815a459f298349a03fc6b3ea3f.tar.gz
haketilo-hydrilla-4d8810538798aa815a459f298349a03fc6b3ea3f.zip
use pyproject.toml for pytest configuration and move all tests to tests/ directory
this commit also fixes inclusion of sample source package's REUSE data in source dist (needed for automated tests)
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 39e2823..b6f87c4 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -10,3 +10,10 @@ requires = ["setuptools>=45", "wheel", "setuptools_scm>=5.0", "babel"]
[tool.setuptools_scm]
write_to = "src/hydrilla/server/_version.py"
+
+[tool.pytest.ini_options]
+minversion = "6.0"
+addopts = "-ra -q"
+testpaths = [
+ "tests"
+]