aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/potassco.scm34
1 files changed, 23 insertions, 11 deletions
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index c8bb094b0a..4fe90f97c5 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -512,21 +512,33 @@ directly from the python command line.")))
(package
(name "python-clingox")
(version "1.2.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/potassco/python-clingox")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0ji0sdqlv0byxmdipwk60afsb82r0rr1j73r7j2508hsfk94m2i8"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/potassco/python-clingox")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ji0sdqlv0byxmdipwk60afsb82r0rr1j73r7j2508hsfk94m2i8"))))
(build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ ;; fixture 's' not found
+ #~(list "--deselect=clingox/tests/test_ast.py::test_rename"
+ "--deselect=clingox/tests/test_ast.py::test_reify"
+ "--deselect=clingox/tests/test_ast.py::test_ast_dict")))
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-wheel))
(propagated-inputs (list python-clingo))
(home-page "https://potassco.org/clingo")
(synopsis "Auxiliary functions for Clingo")
- (description "This package provides additional functions to go along with
-the Python bindings for Clingo.")
+ (description
+ "This package provides additional functions to go along with the Python
+bindings for Clingo.")
(license license:expat)))
(define-public python-asprin