aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-18 01:24:31 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-18 01:24:37 +0000
commit6c86ae62a0ea12e49eddaa3b541340d1ec8e56a2 (patch)
tree1caa8eb62bf7563b3a65b8ecd4c9819f40877ae9 /gnu
parentf79b8a892e900972226c9f77d5e5b7d7703c6ee9 (diff)
downloadguix-6c86ae62a0ea12e49eddaa3b541340d1ec8e56a2.tar.gz
guix-6c86ae62a0ea12e49eddaa3b541340d1ec8e56a2.zip
gnu: python-clingox: Fix build, improve style.
* gnu/packages/potassco.scm (python-clingox): Adjust indentation. [arguments]<test-flags>: Skip 3 tests. [native-inputs]: Add python-pytest, python-setuptools, and python-wheel. [description]: Start from a new line. Change-Id: I0a267df9f23e585ba7619fb8905024cbe17027a8
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/potassco.scm34
1 files changed, 23 insertions, 11 deletions
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index c8bb094b0a..4fe90f97c5 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -512,21 +512,33 @@ directly from the python command line.")))
(package
(name "python-clingox")
(version "1.2.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/potassco/python-clingox")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0ji0sdqlv0byxmdipwk60afsb82r0rr1j73r7j2508hsfk94m2i8"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/potassco/python-clingox")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ji0sdqlv0byxmdipwk60afsb82r0rr1j73r7j2508hsfk94m2i8"))))
(build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ ;; fixture 's' not found
+ #~(list "--deselect=clingox/tests/test_ast.py::test_rename"
+ "--deselect=clingox/tests/test_ast.py::test_reify"
+ "--deselect=clingox/tests/test_ast.py::test_ast_dict")))
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-wheel))
(propagated-inputs (list python-clingo))
(home-page "https://potassco.org/clingo")
(synopsis "Auxiliary functions for Clingo")
- (description "This package provides additional functions to go along with
-the Python bindings for Clingo.")
+ (description
+ "This package provides additional functions to go along with the Python
+bindings for Clingo.")
(license license:expat)))
(define-public python-asprin