aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f0b4555de1..57b41aaba0 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -585,7 +585,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(%upstream-linux-source version hash)
deblob-scripts-5.4)))
-(define-public linux-libre-4.19-version "4.19.295")
+(define-public linux-libre-4.19-version "4.19.296")
(define-public linux-libre-4.19-gnu-revision "gnu1")
(define deblob-scripts-4.19
(linux-libre-deblob-scripts
@@ -595,7 +595,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(base32 "1425mhkfxn18vxn05bb4h3li7x1jl7l1hf1zi8xhnqv3wa31h9wl")))
(define-public linux-libre-4.19-pristine-source
(let ((version linux-libre-4.19-version)
- (hash (base32 "1b1qslpk1kka7nxam48s22xsqd9qmp716hmibgfsjxl5y3jc4cmp")))
+ (hash (base32 "1bk051canr4fb00j6x9ff2wam2f20whw4h4z767x2cn2kmv6cqb3")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-4.19)))
itle='2024-07-19 00:46:07 +0300'>2024-07-19gnu: Add rust-sequoia-wot-0.11....* gnu/packages/sequoia.scm (rust-sequoia-wot-0.11): New variable. (rust-sequoia-wot-0.8): Remove variable. (sequoia-wot): Inherit from rust-sequoia-wot-0.11. [arguments]: Install evlish shell completions. Change-Id: I011b103ada299c1f147b625ad7cf78e5f27735e3 Efraim Flashner 2024-07-19gnu: Add rust-sequoia-cert-store-0.5....* gnu/packages/sequoia.scm (rust-sequoia-cert-store-0.5): New variable. (rust-sequoia-cert-store-0.3): Remove variable. Change-Id: I498f70c92e106ef17b1057bc772bf6ddf372f74b Efraim Flashner 2024-07-19gnu: rust-sequoia-autocrypt-0.25: Update to 0.25.1....* gnu/packages/sequoia.scm (rust-sequoia-autocrypt-0.25): Update to 0.25.1. [cargo-inputs]: Replace rust-base64-0.13 with 0.21. Change-Id: Ib0f510c3740cc746b49704b9bc398eb3f1f29ce0 Efraim Flashner 2024-07-19gnu: Add rust-openpgp-cert-d-0.3....* gnu/packages/sequoia.scm (rust-openpgp-cert-d-0.3): New variable. Change-Id: Ia35a75bed4200836929d009950d65fafe8c250e1 Efraim Flashner 2024-07-19gnu: rust-sequoia-openpgp-1: Update to 1.19.0....* gnu/packages/sequoia.scm (rust-sequoia-openpgp-1): Update to 1.19.0. [arguments]: Adjust cargo-test-flags. [cargo-inputs]: Add rust-aes-gcm-0.10, rust-camellia-0.1, rust-dsa-0.6, rust-x25519-dalek-2. Replace rust-ed25519-1 with 2, rust-ed25519-dalek-1 with 2, rust-idna-0.3 with 0.5, rust-lalrpop-0.19 with 0.20, rust-lalrpop-util-0.19 with 0.20, rust-regex-syntax-0.6 with 0.8, rust-sha1collisiondetection-0.2 with 0.3. Remove rust-generic-array-0.14, rust-rand-0.7, rust-sha-1-0.10, rust-x25519-dalek-ng-1. [cargo-development-inputs]: Replace rust-criterion-0.4 with 0.5, rust-rpassword-6 with 7. (sequoia): Update to 1.19.0. Change-Id: Ica9c098dbe28fc575bb480613efac61286cc550f Efraim Flashner