aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2023-10-11 01:13:28 +0200
committerLeo Famulari <leo@famulari.name>2023-07-23 22:26:05 -0400
commitd38414047edfc7c217c9abc33dd44a4b28af25f7 (patch)
tree52e3a5b1eda926905d9edcd9169ac952747c2eaa /gnu/packages
parent44f32a407f9d66b8ef8af9876f9ad35558becfbb (diff)
downloadguix-d38414047edfc7c217c9abc33dd44a4b28af25f7.tar.gz
guix-d38414047edfc7c217c9abc33dd44a4b28af25f7.zip
gnu: linux-libre 4.19: Update to 4.19.296.
* gnu/packages/linux.scm (linux-libre-4.19-version): Update to 4.19.296. (linux-libre-4.19-pristine-source): Update hash. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f0b4555de1..57b41aaba0 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -585,7 +585,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(%upstream-linux-source version hash)
deblob-scripts-5.4)))
-(define-public linux-libre-4.19-version "4.19.295")
+(define-public linux-libre-4.19-version "4.19.296")
(define-public linux-libre-4.19-gnu-revision "gnu1")
(define deblob-scripts-4.19
(linux-libre-deblob-scripts
@@ -595,7 +595,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(base32 "1425mhkfxn18vxn05bb4h3li7x1jl7l1hf1zi8xhnqv3wa31h9wl")))
(define-public linux-libre-4.19-pristine-source
(let ((version linux-libre-4.19-version)
- (hash (base32 "1b1qslpk1kka7nxam48s22xsqd9qmp716hmibgfsjxl5y3jc4cmp")))
+ (hash (base32 "1bk051canr4fb00j6x9ff2wam2f20whw4h4z767x2cn2kmv6cqb3")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-4.19)))
a ‘guildhall-build-system’ that does the right thing based on guildhall recipes. * union Support sophisticated collision handling when building a union: honor per-package priorities, etc. * add GUIX_ALLOW_EXPENSIVE_TESTS Tests that need to download stuff or otherwise take a long time would only be run when that is defined. * guix build utils ** MAYBE Change ‘ld-wrapper’ to add RPATH for libs passed by file name ** MAYBE Add equivalent to chrpath that uses [[https://gitorious.org/guile-dlhacks/guile-dlhacks/][guile-dlhacks]] ** MAYBE Add a hash-rewriting thing for deep dependency replacement without rebuild See [[https://github.com/NixOS/nixpkgs/commit/d1662d715514e6ef9d3dc29f132f1b3d8e608a18][Shea Levy's `replace-dependency' in Nixpkgs]]. * distro ** port to GNU/Hurd, aka. ‘i686-gnu’ Problems include that current glibc releases do not build on GNU/Hurd. In addition, there haven’t been stable releases of GNU Mach, MiG, and Hurd, which would be a pre-condition. * Installer ** Fix impossibility to restart on error after cow-store has been started See https://lists.gnu.org/archive/html/guix-devel/2018-12/msg00161.html. - Force reboot upon installer failure - Unshare the installer process - Run the installer process in a separate namespace ** Partitioning *** Add RAID support *** Add more partitioning schemes The actual schemes are taken from Debian Installer but some are not implemented yet: like "Separate partitions for /home /var and /tmp". *** Replace wait page "Partition formating is in progress, please wait" Create a new waiting page describing what's being done: [ 20% ] Running mkfs.ext4 on /dev/sda2 ... [ 40% ] Running mkfs.ext4 on /dev/sda3 ... *** Add a confirmation page before formating/partitioning ** Desktop environments *** Allow for no desktop environments Propose to choose between "headless server" and "lightweight X11" in a new page. *** Add services selection feature Add a services page to the configuration. Ask for services to be installed like SSH, bluetooth, TLP in a checkbox list? ** Locale and keymap *** Try to guess user locale and keymap by probing BIOS or HW (dmidecode) ** Timezone *** Regroup everything in one single page Under the form: (UTC + 1) Europe/Paris (UTC + 2) Africa/Cairo ... ** Display issue *** Investigate display issue described here: https://lists.gnu.org/archive/html/guix-devel/2019-01/msg00305.html