aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/erlang-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/erlang-xyz.scm')
-rw-r--r--gnu/packages/erlang-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-xyz.scm
index 9bd0ef0826..07837fde0b 100644
--- a/gnu/packages/erlang-xyz.scm
+++ b/gnu/packages/erlang-xyz.scm
@@ -19,6 +19,7 @@
(define-module (gnu packages erlang-xyz)
#:use-module (gnu packages)
#:use-module (gnu packages erlang)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages python)
#:use-module (gnu packages serialization)
#:use-module (gnu packages tls)
@@ -403,6 +404,33 @@ Erlang/Elixir.")
(home-page "https://hex.pm/packages/yconf")
(license license:asl2.0)))
+(define-public erlang-epam
+ (package
+ (name "erlang-epam")
+ (version "1.0.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hexpm-uri "epam" version))
+ (sha256
+ (base32 "12frsirp8m0ajdb19xi1g86zghhgvld5cgw459n2m9w553kljd1g"))))
+ (build-system rebar-build-system)
+ (native-inputs (list erlang-pc linux-pam))
+ (arguments
+ (list
+ #:tests? #f ; no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'set-environment
+ (lambda _
+ (setenv "HOME" "/tmp")
+ (setenv "CC" "gcc"))))))
+ (synopsis "Helper for PAM authentication support")
+ (description "This package provides epam helper for PAM authentication
+support.")
+ (home-page "https://hex.pm/packages/epam")
+ (license license:asl2.0)))
+
(define-public erlang-unicode-util-compat
(package
(name "erlang-unicode-util-compat")