aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/erlang-xyz.scm
diff options
context:
space:
mode:
authorIgor Goryachev via Guix-patches via <guix-patches@gnu.org>2024-08-05 13:44:55 +0300
committerAndrew Tropin <andrew@trop.in>2024-08-05 17:32:16 +0400
commit14be341953399e2b7656c118191d82f257c6021f (patch)
treeda9db64c921bb15d17357b0f78ce418f6cebd797 /gnu/packages/erlang-xyz.scm
parent18a201260abf194be844ead408018ece31739353 (diff)
downloadguix-14be341953399e2b7656c118191d82f257c6021f.tar.gz
guix-14be341953399e2b7656c118191d82f257c6021f.zip
gnu: Add erlang-epam.
* gnu/packages/erlang-xyz.scm (erlang-epam): New variable. Change-Id: I09e50e3ad2476bf0f96363a20c4b15f2756fe368 Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu/packages/erlang-xyz.scm')
-rw-r--r--gnu/packages/erlang-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-xyz.scm
index 9bd0ef0826..07837fde0b 100644
--- a/gnu/packages/erlang-xyz.scm
+++ b/gnu/packages/erlang-xyz.scm
@@ -19,6 +19,7 @@
(define-module (gnu packages erlang-xyz)
#:use-module (gnu packages)
#:use-module (gnu packages erlang)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages python)
#:use-module (gnu packages serialization)
#:use-module (gnu packages tls)
@@ -403,6 +404,33 @@ Erlang/Elixir.")
(home-page "https://hex.pm/packages/yconf")
(license license:asl2.0)))
+(define-public erlang-epam
+ (package
+ (name "erlang-epam")
+ (version "1.0.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hexpm-uri "epam" version))
+ (sha256
+ (base32 "12frsirp8m0ajdb19xi1g86zghhgvld5cgw459n2m9w553kljd1g"))))
+ (build-system rebar-build-system)
+ (native-inputs (list erlang-pc linux-pam))
+ (arguments
+ (list
+ #:tests? #f ; no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'set-environment
+ (lambda _
+ (setenv "HOME" "/tmp")
+ (setenv "CC" "gcc"))))))
+ (synopsis "Helper for PAM authentication support")
+ (description "This package provides epam helper for PAM authentication
+support.")
+ (home-page "https://hex.pm/packages/epam")
+ (license license:asl2.0)))
+
(define-public erlang-unicode-util-compat
(package
(name "erlang-unicode-util-compat")