aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/docker.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/docker.scm')
-rw-r--r--gnu/packages/docker.scm31
1 files changed, 15 insertions, 16 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index c033486c6a..c6d56a06b1 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -300,24 +300,23 @@ the required network abstractions for applications.")
(inherit docker-libnetwork)
(name "docker-libnetwork-cmd-proxy")
(arguments
- ;; The tests are unsupported on all architectures except x86_64-linux.
- `(#:tests? ,(and (not (%current-target-system))
- (target-x86-64?))
- #:import-path "github.com/docker/libnetwork/cmd/proxy"
- #:unpack-path "github.com/docker/libnetwork"
- #:install-source? #f))
+ (list
+ ;; The tests are unsupported on all architectures except x86_64-linux.
+ #:tests? (and (not (%current-target-system)) (target-x86-64?))
+ #:install-source? #f
+ #:import-path "github.com/docker/libnetwork/cmd/proxy"
+ #:unpack-path "github.com/docker/libnetwork"))
(native-inputs
- `(("go-sctp" ,go-sctp)
- ;; For tests.
- ("logrus" ,go-github-com-sirupsen-logrus)
- ("go-netlink" ,go-netlink)
- ("go-netns" ,go-netns)
- ("go-golang-org-x-crypto"
- ,go-golang-org-x-crypto)
- ("go-golang-org-x-sys" ,go-golang-org-x-sys)))
+ (list go-github-com-sirupsen-logrus ; for tests.
+ go-github-com-vishvananda-netlink
+ go-github-com-vishvananda-netns
+ go-golang-org-x-crypto
+ go-golang-org-x-sys
+ go-sctp))
(synopsis "Docker user-space proxy")
- (description "A proxy running in the user space. It is used by the
-built-in registry server of Docker.")
+ (description
+ "This package provides a proxy running in the user space. It is used by
+the built-in registry server of Docker.")
(license license:asl2.0)))
;; TODO: Patch out modprobes for ip_vs, nf_conntrack,