aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/docker.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-08 13:05:56 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-08 13:05:56 +0100
commitd7d779a3eff9d7875d491e4180da665f6d2a1b86 (patch)
tree5dacbdb41a26fd52e1d8e3d92425f8917ff8a3cc /gnu/packages/docker.scm
parent7bf1d7aeaffba15c4f680f93ae88fbef25427252 (diff)
parent9a4cd495a428ddf90eeafcaea883af80350574d5 (diff)
downloadguix-d7d779a3eff9d7875d491e4180da665f6d2a1b86.tar.gz
guix-d7d779a3eff9d7875d491e4180da665f6d2a1b86.zip
Merge remote-tracking branch 'origin/go-team'
Change-Id: Ib66e48c4cb84e9e97ebcec334ab0b9f3dbfb1457
Diffstat (limited to 'gnu/packages/docker.scm')
-rw-r--r--gnu/packages/docker.scm31
1 files changed, 15 insertions, 16 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index c033486c6a..c6d56a06b1 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -300,24 +300,23 @@ the required network abstractions for applications.")
(inherit docker-libnetwork)
(name "docker-libnetwork-cmd-proxy")
(arguments
- ;; The tests are unsupported on all architectures except x86_64-linux.
- `(#:tests? ,(and (not (%current-target-system))
- (target-x86-64?))
- #:import-path "github.com/docker/libnetwork/cmd/proxy"
- #:unpack-path "github.com/docker/libnetwork"
- #:install-source? #f))
+ (list
+ ;; The tests are unsupported on all architectures except x86_64-linux.
+ #:tests? (and (not (%current-target-system)) (target-x86-64?))
+ #:install-source? #f
+ #:import-path "github.com/docker/libnetwork/cmd/proxy"
+ #:unpack-path "github.com/docker/libnetwork"))
(native-inputs
- `(("go-sctp" ,go-sctp)
- ;; For tests.
- ("logrus" ,go-github-com-sirupsen-logrus)
- ("go-netlink" ,go-netlink)
- ("go-netns" ,go-netns)
- ("go-golang-org-x-crypto"
- ,go-golang-org-x-crypto)
- ("go-golang-org-x-sys" ,go-golang-org-x-sys)))
+ (list go-github-com-sirupsen-logrus ; for tests.
+ go-github-com-vishvananda-netlink
+ go-github-com-vishvananda-netns
+ go-golang-org-x-crypto
+ go-golang-org-x-sys
+ go-sctp))
(synopsis "Docker user-space proxy")
- (description "A proxy running in the user space. It is used by the
-built-in registry server of Docker.")
+ (description
+ "This package provides a proxy running in the user space. It is used by
+the built-in registry server of Docker.")
(license license:asl2.0)))
;; TODO: Patch out modprobes for ip_vs, nf_conntrack,