aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/maven.scm25
1 files changed, 22 insertions, 3 deletions
diff --git a/gnu/packages/maven.scm b/gnu/packages/maven.scm
index 9940558ead..126e077208 100644
--- a/gnu/packages/maven.scm
+++ b/gnu/packages/maven.scm
@@ -661,9 +661,14 @@ replacement with improvements.")
(arguments
`(#:jar-name "maven-plugin-annotations.jar"
#:source-dir "maven-plugin-annotations/src/main/java"
- #:tests? #f))
- (inputs
- `(("maven-artifact" ,maven-artifact)))
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'install
+ (install-from-pom "maven-plugin-annotations/pom.xml")))))
+ (propagated-inputs
+ `(("maven-artifact" ,maven-artifact)
+ ("maven-plugin-tools-parent-pom" ,maven-plugin-tools-parent-pom)))
(native-inputs
`(("unzip" ,unzip)))
(home-page "https://maven.apache.org/plugin-tools/maven-plugin-annotations/")
@@ -671,6 +676,20 @@ replacement with improvements.")
(description "This package contains Java 5 annotations for use in Mojos.")
(license license:asl2.0)))
+(define maven-plugin-tools-parent-pom
+ (package
+ (inherit maven-plugin-annotations)
+ (name "maven-plugin-tools-parent-pom")
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (install-pom-file "pom.xml")))))
+ (propagated-inputs '())))
+
(define-public maven-wagon-provider-api
(package
(name "maven-wagon-provider-api")
x/POTFILES.in: Add it. * gnu/installer/record.scm (<installer>): Add 'help-menu' and 'help-page' fields, (installer-help-menu, installer-help-page): new exported procedures. * gnu/installer/newt.scm (init): Set the help line, (help-menu, help-page): new procedures used ... (newt-installer): ... here. * gnu/installer/newt/keymap.scm (run-layout-page): Add a context argument to differenciate the help context from the main one, (run-keymap-page): add a context argument and pass it to run-layout-page. * gnu/installer.scm (compute-keymap-step): Add a context argument and pass it to 'installer-keymap-page', (installer-steps): set the help menu and pass the appropriate context to compute-keymap-step calls, (guile-newt): update to revision 2. Mathieu Othacehe 2020-04-02nls: Add Tamil translation....* po/guix/LINGUAS: Add 'ta'. * po/guix/ta.po: New file. Julien Lepiller 2020-03-23nls: Update.Ludovic Courtès