aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-web.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index c252470815..b7a1b71d0b 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -3605,6 +3605,43 @@ of the specification.")
support.")
(license license:expat)))
+(define-public go-github-com-shurcool-httpfs
+ (package
+ (name "go-github-com-shurcool-httpfs")
+ (version "0.0.0-20230704072500-f1e31cf0ba5c")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/shurcooL/httpfs")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1m0jjnfzr8372cjx0zjm2zm695kwaz8l1yk7gzgn05biadsklprm"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/shurcooL/httpfs"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: Replace when go-build-system supports nested path.
+ (delete 'build)
+ (replace 'check
+ (lambda* (#:key import-path tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
+ (native-inputs
+ (list go-golang-org-x-tools))
+ (propagated-inputs
+ (list go-github-com-shurcool-httpgzip))
+ (home-page "https://github.com/shurcooL/httpfs")
+ (synopsis "Utilities for @code{http.FileSystem}")
+ (description
+ "Collection of Go packages for working with the +@code{http.FileSystem}
+interface.")
+ (license license:expat)))
+
(define-public go-github-com-shurcool-httpgzip
(package
(name "go-github-com-shurcool-httpgzip")