aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Nikkilä <hello@lnikki.la>2024-08-21 21:46:26 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 20:46:47 +0100
commitbb6c91c9b9a924a8af87aad324960974f4a5ea8c (patch)
tree23edfbcbaf999d9832baf67997579f773c5930f1
parent7ff7ca4b700c61cd6ae5f83058897d3bbb3a22aa (diff)
downloadguix-bb6c91c9b9a924a8af87aad324960974f4a5ea8c.tar.gz
guix-bb6c91c9b9a924a8af87aad324960974f4a5ea8c.zip
gnu: Add go-github-com-shurcool-httpfs.
* gnu/packages/golang-web.scm (go-github-com-shurcool-httpfs): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: Ie0413ac3c9bd50365f197b2c6f6ec4f00fbc0d97
-rw-r--r--gnu/packages/golang-web.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index c252470815..b7a1b71d0b 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -3605,6 +3605,43 @@ of the specification.")
support.")
(license license:expat)))
+(define-public go-github-com-shurcool-httpfs
+ (package
+ (name "go-github-com-shurcool-httpfs")
+ (version "0.0.0-20230704072500-f1e31cf0ba5c")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/shurcooL/httpfs")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1m0jjnfzr8372cjx0zjm2zm695kwaz8l1yk7gzgn05biadsklprm"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/shurcooL/httpfs"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: Replace when go-build-system supports nested path.
+ (delete 'build)
+ (replace 'check
+ (lambda* (#:key import-path tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
+ (native-inputs
+ (list go-golang-org-x-tools))
+ (propagated-inputs
+ (list go-github-com-shurcool-httpgzip))
+ (home-page "https://github.com/shurcooL/httpfs")
+ (synopsis "Utilities for @code{http.FileSystem}")
+ (description
+ "Collection of Go packages for working with the +@code{http.FileSystem}
+interface.")
+ (license license:expat)))
+
(define-public go-github-com-shurcool-httpgzip
(package
(name "go-github-com-shurcool-httpgzip")