aboutsummaryrefslogtreecommitdiff
path: root/guix.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:54 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:54 +0000
commit1382f7697adba7eb401580a90d40054caa8f8d51 (patch)
tree5a83e9dc40fcd419d4622ac3f9cd74606f2c0349 /guix.scm
parent8851c55b538f62534f16c1dd1e22657ef2f3c916 (diff)
downloadguix-1382f7697adba7eb401580a90d40054caa8f8d51.tar.gz
guix-1382f7697adba7eb401580a90d40054caa8f8d51.zip
gnu: Add ghc-xcb-types.
* gnu/packages/xorg.scm (ghc-xcb-types): New variable. Change-Id: I42d1d49251e9c3d56aecf012a52fff34e678bd94 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'guix.scm')
0 files changed, 0 insertions, 0 deletions
/nix/libstore/gc.cc?id=d445c30ea6f9693454ca96bae9089ba8738a6f78'>nix/libstore/gc.cc5
1 files changed, 4 insertions, 1 deletions
diff --git a/nix/libstore/gc.cc b/nix/libstore/gc.cc
index 8bc4e01eb0..e1d0765154 100644
--- a/nix/libstore/gc.cc
+++ b/nix/libstore/gc.cc
@@ -455,7 +455,10 @@ void LocalStore::deletePathRecursive(GCState & state, const Path & path)
throw SysError(format("unable to rename `%1%' to `%2%'") % path % tmp);
state.bytesInvalidated += size;
} catch (SysError & e) {
- if (e.errNo == ENOSPC) {
+ /* In a Docker container, rename(2) returns EXDEV when the source
+ and destination are not both on the "top layer". See:
+ https://bugs.gnu.org/41607 */
+ if (e.errNo == ENOSPC || e.errNo == EXDEV) {
printMsg(lvlInfo, format("note: can't create move `%1%': %2%") % path % e.msg());
deleteGarbage(state, path);
}