aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:54 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:54 +0000
commit1382f7697adba7eb401580a90d40054caa8f8d51 (patch)
tree5a83e9dc40fcd419d4622ac3f9cd74606f2c0349
parent8851c55b538f62534f16c1dd1e22657ef2f3c916 (diff)
downloadguix-1382f7697adba7eb401580a90d40054caa8f8d51.tar.gz
guix-1382f7697adba7eb401580a90d40054caa8f8d51.zip
gnu: Add ghc-xcb-types.
* gnu/packages/xorg.scm (ghc-xcb-types): New variable. Change-Id: I42d1d49251e9c3d56aecf012a52fff34e678bd94 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/xorg.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 562c0facf0..369374860a 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -39,6 +39,7 @@
;;; Copyright © 2023, 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2023, 2024 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2023, 2024 Kaelyn Takata <kaelyn.alexi@protonmail.com>
+;;; Copyright © 2024 Nicolas Graves <ngraves@ngraves.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -63,6 +64,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system haskell)
#:use-module (guix build-system meson)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
@@ -90,6 +92,9 @@
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gperf)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages haskell)
+ #:use-module (gnu packages haskell-apps)
+ #:use-module (gnu packages haskell-check)
#:use-module (gnu packages haskell-xyz)
#:use-module (gnu packages inkscape)
#:use-module (gnu packages image)
@@ -974,6 +979,26 @@ rendering commands to the X server.")
(license license:x11)
(properties `((superseded . ,xorgproto)))))
+(define-public ghc-xcb-types
+ (package
+ (name "ghc-xcb-types")
+ (version "0.13.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "xcb-types" version))
+ (sha256
+ (base32 "0qdfj4d83b1fjmlysqncgi65ldf3qnrsj4lync95mgbaq2kzxj2r"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "xcb-types")))
+ (inputs (list ghc-xml))
+ (home-page "http://community.haskell.org/~aslatter/code/xcb-types")
+ (synopsis "Parse XML files used by the XCB project")
+ (description
+ "This package provides types which mirror the structures used in the XCB code
+generation XML files and parses these XML files into Haskell data structures.")
+ (license license:bsd-3)))
+
(define-public iceauth
(package
(name "iceauth")