aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-18 01:27:44 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-18 01:27:49 +0000
commitf96f094df25b663b1272bee9e31c468caf766b31 (patch)
tree2d2c5e67c62be48291901426cb4ac745d3266c73 /gnu
parent6c86ae62a0ea12e49eddaa3b541340d1ec8e56a2 (diff)
downloadguix-f96f094df25b663b1272bee9e31c468caf766b31.tar.gz
guix-f96f094df25b663b1272bee9e31c468caf766b31.zip
gnu: python-clintest: Update to 0.3.0.
* gnu/packages/potassco.scm (python-clintest): Update to 0.3.0, fix build. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: I22bd8019cc1b6f2d1a2c7fe40bfb98ad5679f9f1
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/potassco.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index 4fe90f97c5..d7da301ba8 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -757,7 +757,7 @@ which allows user interfaces to be specified entirely as a logic program.")
(define-public python-clintest
(package
(name "python-clintest")
- (version "0.2.0")
+ (version "0.3.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -766,10 +766,10 @@ which allows user interfaces to be specified entirely as a logic program.")
(file-name (git-file-name name version))
(sha256
(base32
- "0xzbby9ram55h87ykm652kgm45b8rlhbjc8gjkz308h1jnjllmmy"))))
+ "1k8y3pm3w81n2appfl98drv1hpgjjqi2hxb1aa52y2m831lir38s"))))
(build-system pyproject-build-system)
(inputs (list python-clingo))
- (native-inputs (list python-pytest))
+ (native-inputs (list python-pytest python-setuptools python-wheel))
(home-page "https://potassco.org/clintest/")
(synopsis "Test framework for clingo programs")
(description "Clintest is a framework for unit testing clingo programs.