aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-11 23:11:08 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:22 +0000
commite3b89041bfb0606e62580a020da9a4371e9bb424 (patch)
treed4e0630426043ce880777429a0f81dc1b0cdb8f9 /gnu
parent925ae7d5c74c98067dda7e03babfd0ee9681d517 (diff)
downloadguix-e3b89041bfb0606e62580a020da9a4371e9bb424.tar.gz
guix-e3b89041bfb0606e62580a020da9a4371e9bb424.zip
gnu: python-editables: Update to 0.5.
* gnu/packages/python-build.scm (python-editables): Update to 0.5. [build-system]: Swap to pyproject-build-system. [arguments]<tests>: Disable to avoid any cycles with python-pytest. [native-inputs]: Add python-flit-core. Change-Id: I2f7d6d70541f372753dc168e74e2c8e8787c946e
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-build.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index dad6d61cf7..87e1bc4116 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -698,7 +698,7 @@ them as the version argument or in a SCM managed file.")
(define-public python-editables
(package
(name "python-editables")
- (version "0.3")
+ (version "0.5")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -707,8 +707,11 @@ them as the version argument or in a SCM managed file.")
(file-name (git-file-name name version))
(sha256
(base32
- "1gbfkgzmrmbd4ycshm09fr2wd4f1n9gq7s567jgkavhfkn7s2pn1"))))
- (build-system python-build-system)
+ "1bp959fz987jvrnkilhyr41fw4g00g9jfyiwmfvy96hv1yl68w8b"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:tests? #f)) ;avoid extra dependencies such as pytest
+ (native-inputs
+ (list python-flit-core))
(home-page "https://github.com/pfmoore/editables")
(synopsis "Editable installations")
(description "This library supports the building of wheels which, when