aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2024-11-07 23:22:08 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:05:24 +0200
commitd49ceac5ba4b2d5867c4fb81f57d476433307fd9 (patch)
tree797eca9bd6f91cc249aa8ecb0009fc4604590aa4 /gnu
parenta487d05126ea548503232d344d6cd1d7da02e55e (diff)
downloadguix-d49ceac5ba4b2d5867c4fb81f57d476433307fd9.tar.gz
guix-d49ceac5ba4b2d5867c4fb81f57d476433307fd9.zip
gnu: Add rust-gdk4-wayland-0.7.
* gnu/packages/crates-gtk.scm (rust-gdk4-wayland-0.7): New variable. Change-Id: If35091927a32854f4c94eae86446498077776351 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-gtk.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/crates-gtk.scm b/gnu/packages/crates-gtk.scm
index d7aabf8c1b..9a706cbc93 100644
--- a/gnu/packages/crates-gtk.scm
+++ b/gnu/packages/crates-gtk.scm
@@ -1224,6 +1224,38 @@
#:cargo-development-inputs (("rust-shell-words" ,rust-shell-words-1)
("rust-tempfile" ,rust-tempfile-3))))))
+(define-public rust-gdk4-wayland-0.7
+ (package
+ (name "rust-gdk4-wayland")
+ (version "0.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "gdk4-wayland" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "04zkspjs1r6l4gj241p9xm2zmp91phm1khakw5jvsm8yy4pi1f8d"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-gdk4" ,rust-gdk4-0.7)
+ ("rust-gdk4-wayland-sys" ,rust-gdk4-wayland-sys-0.7)
+ ("rust-gio" ,rust-gio-0.18)
+ ("rust-glib" ,rust-glib-0.18)
+ ("rust-khronos-egl" ,rust-khronos-egl-5)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-wayland-backend" ,rust-wayland-backend-0.1)
+ ("rust-wayland-client" ,rust-wayland-client-0.30)
+ ("rust-xkb" ,rust-xkb-0.3))
+ #:cargo-development-inputs
+ (("rust-gir-format-check" ,rust-gir-format-check-0.1))))
+ (native-inputs (list pkg-config))
+ (inputs (list glib gtk))
+ (home-page "https://gtk-rs.org/gtk4-rs")
+ (synopsis "Rust bindings of the GDK 4 Wayland library")
+ (description
+ "This package provides Rust bindings of the GDK 4 Wayland library.")
+ (license license:expat)))
+
(define-public rust-gdk4-wayland-sys-0.7
(package
(name "rust-gdk4-wayland-sys")