aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2024-11-07 23:22:07 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:05:24 +0200
commita487d05126ea548503232d344d6cd1d7da02e55e (patch)
treec90ca99eccc7936a59447b11d17b648cd9511bd8 /gnu
parent3f3c2408a8e816296ec63af170b5692e6f769870 (diff)
downloadguix-a487d05126ea548503232d344d6cd1d7da02e55e.tar.gz
guix-a487d05126ea548503232d344d6cd1d7da02e55e.zip
gnu: Add rust-xkb-0.3.
* gnu/packages/crates-graphics.scm (rust-xkb-0.3): New variable. Change-Id: Ie8a93fc23aae86160a2f47b2e5631fc1e6fc9e50 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-graphics.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 1e3e9a6e9a..654928cb15 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -6572,6 +6572,32 @@ for @code{libxkbcommon}.")
"Dynamically loaded xkbcommon and xkbcommon-x11 Rust bindings.")
(license license:expat)))
+(define-public rust-xkb-0.3
+ (package
+ (name "rust-xkb")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "xkb" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "03rfx8n3pajc95riksnshh3aqm8dqij2iis5icl88pa6ylk9x0gj"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-bitflags" ,rust-bitflags-1)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-xcb" ,rust-xcb-1)
+ ("rust-xkbcommon-sys" ,rust-xkbcommon-sys-1))))
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list clang libxkbcommon-1.5 mesa))
+ (home-page "https://github.com/meh/rust-xkb")
+ (synopsis "Rusty wrapper around libxkbcommon")
+ (description "This package provides Rusty wrapper around libxkbcommon.")
+ (license license:wtfpl2)))
+
(define-public rust-xkeysym-0.2
(package
(name "rust-xkeysym")