aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-10-29 10:01:54 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-12-18 23:28:17 +0900
commitcb7cea7c8c0d455b6f4381726ba07616bb42f9ce (patch)
tree2b096b8ae1bb3dea7ee4121aaea7e4de706e148a /gnu
parent116d23760d807f8d1fbbd65fd0699fbccb568ed5 (diff)
downloadguix-cb7cea7c8c0d455b6f4381726ba07616bb42f9ce.tar.gz
guix-cb7cea7c8c0d455b6f4381726ba07616bb42f9ce.zip
gnu: ogre: Add support for Wayland, Vulkan and Bullet.
* gnu/packages/graphics.scm (ogre) [configure-flags]: Add -DOGRE_BUILD_RENDERSYSTEM_VULKAN=ON. [native-inputs]: Add vulkan-headers. [inputs]: Add bullet, glslang, spirv-tools and wayland. Change-Id: I77f8964f36facd40f48a80006cfaa0a17c7971e5
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/graphics.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 9495a6f9f8..b4bd05ea8e 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1219,6 +1219,7 @@ frames per second (FPS), temperatures, CPU/GPU load and more.")
(list (string-append "-DCMAKE_INSTALL_RPATH=" runpath)
"-DIMGUI_DIR=../imgui-source"
"-DOGRE_BUILD_DEPENDENCIES=OFF"
+ "-DOGRE_BUILD_RENDERSYSTEM_VULKAN=ON"
"-DOGRE_BUILD_TESTS=TRUE"
"-DOGRE_INSTALL_DOCS=TRUE"
"-DOGRE_INSTALL_SAMPLES=TRUE"
@@ -1229,16 +1230,21 @@ frames per second (FPS), temperatures, CPU/GPU load and more.")
("googletest" ,googletest)
("pkg-config" ,pkg-config)
("python" ,python)
+ ("vulkan-headers" ,vulkan-headers)
("xorg-server-for-tests" ,xorg-server-for-tests)))
(inputs
- (list freeimage
+ (list bullet
+ freeimage
freetype
+ glslang
libxaw
libxrandr
libxt
mesa
pugixml
sdl2
+ spirv-tools
+ wayland
zlib))
(synopsis "Scene-oriented, flexible 3D engine written in C++")
(description