aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-10-28 23:31:17 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-12-18 23:28:17 +0900
commit116d23760d807f8d1fbbd65fd0699fbccb568ed5 (patch)
treeacf62879e72fa23bddd591d555b65e617c46b2ff /gnu
parent801c930fc63f1077ea4e3d65fd47875ff4e1735e (diff)
downloadguix-116d23760d807f8d1fbbd65fd0699fbccb568ed5.tar.gz
guix-116d23760d807f8d1fbbd65fd0699fbccb568ed5.zip
gnu: ogre: Update to 14.3.2.
* gnu/packages/graphics.scm (ogre): Update to 14.3.2. [phases] <do-not-attempt-building-gtest, run-x-server>: New phases. [native-inputs]: Update imgui source to latest. Add xorg-server-for-tests. Change-Id: Iabe6bb580106158976e7193bbb27d59df2466e29
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/graphics.scm22
1 files changed, 16 insertions, 6 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 696403f7a5..9495a6f9f8 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -21,7 +21,7 @@
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
-;;; Copyright © 2020, 2021, 2022, 2023, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020-2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
;;; Copyright © 2021 Antoine Côté <antoine.cote@posteo.net>
;;; Copyright © 2021 Andy Tai <atai@atai.org>
@@ -1177,7 +1177,7 @@ frames per second (FPS), temperatures, CPU/GPU load and more.")
(define-public ogre
(package
(name "ogre")
- (version "13.3.1")
+ (version "14.3.2")
(source
(origin
(method git-fetch)
@@ -1186,12 +1186,17 @@ frames per second (FPS), temperatures, CPU/GPU load and more.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "157vpfzivg2wf349glyd0cpbyaw1j3fm4nggban70pghql3x48kb"))))
+ (base32 "0acpwj0kj48jn2vv195cn6951gynz68zwji5sj3m06dj8ciw9r1h"))))
(build-system cmake-build-system)
(arguments
(list
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'do-not-attempt-building-gtest
+ (lambda _
+ (substitute* "Tests/CMakeLists.txt"
+ (("NOT EXISTS \\$\\{PROJECT_BINARY_DIR}/googletest-1.11.0")
+ "FALSE"))))
(add-before 'configure 'unpack-imgui
(lambda _
(copy-recursively #$(this-package-native-input "imgui-source")
@@ -1202,7 +1207,11 @@ frames per second (FPS), temperatures, CPU/GPU load and more.")
;; it.
(lambda _
(substitute* "CMakeLists.txt"
- (("set\\(CMAKE_INSTALL_RPATH .*") "")))))
+ (("set\\(CMAKE_INSTALL_RPATH .*") ""))))
+ (add-before 'check 'run-x-server
+ (lambda _
+ (system "Xvfb &")
+ (setenv "DISPLAY" ":0"))))
#:configure-flags
#~(let ((runpath (string-join (list (string-append #$output "/lib")
(string-append #$output "/lib/OGRE"))
@@ -1216,10 +1225,11 @@ frames per second (FPS), temperatures, CPU/GPU load and more.")
"-DOGRE_INSTALL_SAMPLES_SOURCE=TRUE"))))
(native-inputs
`(("doxygen" ,doxygen)
- ("imgui-source" ,(package-source imgui-1.86))
+ ("imgui-source" ,(package-source imgui))
("googletest" ,googletest)
("pkg-config" ,pkg-config)
- ("python" ,python)))
+ ("python" ,python)
+ ("xorg-server-for-tests" ,xorg-server-for-tests)))
(inputs
(list freeimage
freetype