aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-03-11 06:57:40 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-03-12 09:04:06 -0500
commitca07cca4d85b213350e1a9c70d37558afb98be7b (patch)
tree2d22ec6a8287ecd503b83c9c86894e0563d5adcd /gnu
parent47ee723731bccebd71008cdeb294ec6b02634575 (diff)
downloadguix-ca07cca4d85b213350e1a9c70d37558afb98be7b.tar.gz
guix-ca07cca4d85b213350e1a9c70d37558afb98be7b.zip
gnu: gdk-pixbuf+svg: Add a debug output.
* gnu/packages/gtk.scm (gdk-pixbuf+svg): Fix typo in comment. [arguments]: Rewrite using 'substitute-keyword-arguments', so that all phases from the gdk-pixbuf package are reused.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm38
1 files changed, 18 insertions, 20 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index ddf8068cc2..8c23b41192 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -621,33 +621,31 @@ in the GNOME project.")
(home-page "https://developer.gnome.org/gdk-pixbuf/")))
;; To build gdk-pixbuf with SVG support, we need librsvg, and librsvg depends
-;; on gdk-pixbuf, so this new varibale. Also, librsvg adds 90MiB to the
+;; on gdk-pixbuf, so this new variable. Also, librsvg adds 90MiB to the
;; closure size.
(define-public gdk-pixbuf+svg
- (package (inherit gdk-pixbuf)
+ (package
+ (inherit gdk-pixbuf)
(name "gdk-pixbuf+svg")
(inputs
`(("librsvg" ,librsvg)
,@(package-inputs gdk-pixbuf)))
(arguments
- '(#:configure-flags '("-Dinstalled-tests=false")
- #:tests? #f ; tested by the gdk-pixbuf package already
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'register-svg-loader
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (librsvg (assoc-ref inputs "librsvg"))
- (loaders
- (append
- (find-files out "^libpixbufloader-.*\\.so$")
- (find-files librsvg "^libpixbufloader-.*\\.so$")))
- (gdk-pixbuf-query-loaders
- (string-append out "/bin/gdk-pixbuf-query-loaders")))
- (apply invoke
- gdk-pixbuf-query-loaders
- "--update-cache"
- loaders)))))))
+ (substitute-keyword-arguments (package-arguments gdk-pixbuf)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'install 'register-svg-loader
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (librsvg (assoc-ref inputs "librsvg"))
+ (loaders
+ (append
+ (find-files out "^libpixbufloader-.*\\.so$")
+ (find-files librsvg "^libpixbufloader-.*\\.so$")))
+ (gdk-pixbuf-query-loaders
+ (string-append out "/bin/gdk-pixbuf-query-loaders")))
+ (apply invoke gdk-pixbuf-query-loaders
+ "--update-cache" loaders))))))))
(synopsis
"GNOME image loading and manipulation library, with SVG support")))