aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-03-11 06:57:04 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-03-12 09:04:06 -0500
commit47ee723731bccebd71008cdeb294ec6b02634575 (patch)
treed7b8b00a725f6b8b325d558c69e61dc781f84c16 /gnu
parentd2a97aa421e5501f3633bae490e4244680678612 (diff)
downloadguix-47ee723731bccebd71008cdeb294ec6b02634575.tar.gz
guix-47ee723731bccebd71008cdeb294ec6b02634575.zip
gnu: gdk-pixbuf: Fix indentation.
* gnu/packages/gtk.scm (gdk-pixbuf): Fix indentation.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm120
1 files changed, 60 insertions, 60 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 096424e8e3..ddf8068cc2 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -554,71 +554,71 @@ highlighting and other features typical of a source code editor.")
(define-public gdk-pixbuf
(package
- (name "gdk-pixbuf")
- (version "2.40.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "1rnlx9yfw970maxi2x6niaxmih5la11q1ilr7gzshz2kk585k0hm"))))
- (build-system meson-build-system)
- (outputs '("out" "debug"))
- (arguments
- `(#:configure-flags '("-Dinstalled_tests=false")
- #:modules ((guix build meson-build-system)
- (guix build utils)
- (srfi srfi-1))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'disable-failing-tests
- (lambda _
- (substitute* "tests/meson.build"
- ;; XXX FIXME: This test fails on armhf machines with:
- ;; SKIP Not enough memory to load bitmap image
- ;; ERROR: cve-2015-4491 - too few tests run (expected 4, got 2)
- ((".*'cve-2015-4491'.*") "")
- ;; XXX FIXME: This test fails with:
- ;; ERROR:pixbuf-jpeg.c:74:test_type9_rotation_exif_tag:
- ;; assertion failed (error == NULL): Data differ
- ;; (gdk-pixbuf-error-quark, 0)
- ((".*'pixbuf-jpeg'.*") ""))))
- (replace 'shrink-runpath
- ;; Workaround until core-updates is merged (this is fixed in commit
- ;; ca080b3efb).
- (lambda* (#:key outputs #:allow-other-keys #:rest args)
- (apply (assoc-ref %standard-phases 'shrink-runpath)
- `(,@args #:outputs ,(alist-delete "debug" outputs)))))
- ;; The slow tests take longer than the specified timeout.
- ,@(if (any (cute string=? <> (%current-system))
- '("armhf-linux" "aarch64-linux"))
- '((replace 'check
- (lambda _
- (invoke "meson" "test" "--timeout-multiplier" "5"))))
- '()))))
- (propagated-inputs
- `(;; Required by gdk-pixbuf-2.0.pc
- ("glib" ,glib)
- ("libpng" ,libpng)
- ;; Used for testing and required at runtime.
- ("shared-mime-info" ,shared-mime-info)))
- (inputs
- `(("libjpeg" ,libjpeg-turbo)
- ("libtiff" ,libtiff)
- ("libx11" ,libx11)))
- (native-inputs
+ (name "gdk-pixbuf")
+ (version "2.40.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1rnlx9yfw970maxi2x6niaxmih5la11q1ilr7gzshz2kk585k0hm"))))
+ (build-system meson-build-system)
+ (outputs '("out" "debug"))
+ (arguments
+ `(#:configure-flags '("-Dinstalled_tests=false")
+ #:modules ((guix build meson-build-system)
+ (guix build utils)
+ (srfi srfi-1))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ (substitute* "tests/meson.build"
+ ;; XXX FIXME: This test fails on armhf machines with:
+ ;; SKIP Not enough memory to load bitmap image
+ ;; ERROR: cve-2015-4491 - too few tests run (expected 4, got 2)
+ ((".*'cve-2015-4491'.*") "")
+ ;; XXX FIXME: This test fails with:
+ ;; ERROR:pixbuf-jpeg.c:74:test_type9_rotation_exif_tag:
+ ;; assertion failed (error == NULL): Data differ
+ ;; (gdk-pixbuf-error-quark, 0)
+ ((".*'pixbuf-jpeg'.*") ""))))
+ (replace 'shrink-runpath
+ ;; Workaround until core-updates is merged (this is fixed in commit
+ ;; ca080b3efb).
+ (lambda* (#:key outputs #:allow-other-keys #:rest args)
+ (apply (assoc-ref %standard-phases 'shrink-runpath)
+ `(,@args #:outputs ,(alist-delete "debug" outputs)))))
+ ;; The slow tests take longer than the specified timeout.
+ ,@(if (any (cute string=? <> (%current-system))
+ '("armhf-linux" "aarch64-linux"))
+ '((replace 'check
+ (lambda _
+ (invoke "meson" "test" "--timeout-multiplier" "5"))))
+ '()))))
+ (propagated-inputs
+ `( ;; Required by gdk-pixbuf-2.0.pc
+ ("glib" ,glib)
+ ("libpng" ,libpng)
+ ;; Used for testing and required at runtime.
+ ("shared-mime-info" ,shared-mime-info)))
+ (inputs
+ `(("libjpeg" ,libjpeg-turbo)
+ ("libtiff" ,libtiff)
+ ("libx11" ,libx11)))
+ (native-inputs
`(("pkg-config" ,pkg-config)
("gettext" ,gettext-minimal)
("glib" ,glib "bin") ; glib-mkenums, etc.
("gobject-introspection" ,gobject-introspection))) ; g-ir-compiler, etc.
- (synopsis "GNOME image loading and manipulation library")
- (description
- "GdkPixbuf is a library for image loading and manipulation developed
+ (synopsis "GNOME image loading and manipulation library")
+ (description
+ "GdkPixbuf is a library for image loading and manipulation developed
in the GNOME project.")
- (license license:lgpl2.0+)
- (home-page "https://developer.gnome.org/gdk-pixbuf/")))
+ (license license:lgpl2.0+)
+ (home-page "https://developer.gnome.org/gdk-pixbuf/")))
;; To build gdk-pixbuf with SVG support, we need librsvg, and librsvg depends
;; on gdk-pixbuf, so this new varibale. Also, librsvg adds 90MiB to the