aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-12-16 16:43:43 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:20 +0100
commitbee74a60b0080ff51fe579359e0d5eedb02212ac (patch)
tree29b6d68120778f90dc9a3fbdff61d09771682b98 /gnu
parent599704cef319ba362c6a2c73fec63f7ef74628ea (diff)
downloadguix-bee74a60b0080ff51fe579359e0d5eedb02212ac.tar.gz
guix-bee74a60b0080ff51fe579359e0d5eedb02212ac.zip
gnu: Add python-time-machine.
* gnu/packages/python-check.scm (python-time-machine): New variable. Change-Id: I5fce1caf7e659ae349de765a31cc78195d16d703
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-check.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 047edfd526..60345ff350 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -56,6 +56,7 @@
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
+ #:use-module (gnu packages time)
#:use-module (gnu packages version-control)
#:use-module (gnu packages web)
#:use-module (gnu packages xml)
@@ -2939,6 +2940,24 @@ Python environments, similar to @code{tox}. Unlike tox, Nox uses a standard
Python file for configuration.")
(license license:asl2.0)))
+(define-public python-time-machine
+ (package
+ (name "python-time-machine")
+ (version "2.16.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "time_machine" version))
+ (sha256
+ (base32 "1qn7cj9lx3m7pwa8ak1106f9c54yvpa996x84gfqmyfjfg1ar6aa"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-dateutil))
+ (native-inputs (list python-setuptools python-wheel))
+ (home-page "https://github.com/adamchainz/time-machine")
+ (synopsis "Travel through time in your tests.")
+ (description "This package lets you set a different time for your tests.")
+ (license license:expat)))
+
(define-public python-tox
(package
(name "python-tox")