aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-12-16 16:40:28 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:20 +0100
commit599704cef319ba362c6a2c73fec63f7ef74628ea (patch)
treec80eb0a6394ecf74a5cba2d6a157d061a5704e5c /gnu
parent23aa7ba596f947f859d9a3cdbf3bb7f9a6c9fd28 (diff)
downloadguix-599704cef319ba362c6a2c73fec63f7ef74628ea.tar.gz
guix-599704cef319ba362c6a2c73fec63f7ef74628ea.zip
gnu: python-nox: Update to 2024.10.09.
* gnu/packages/python-check.scm (python-nox): Update to 2024.10.09. [native-inputs]: Add python-hatchling; remove python-setuptools and python-wheel. [arguments]: Remove custom build phases. Change-Id: I3a446b7b1ef1d73356d5ba87b0c6812a08e4d3c3
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-check.scm28
1 files changed, 5 insertions, 23 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index f70028c65f..047edfd526 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -2908,7 +2908,7 @@ which make writing and running functional and integration tests easier.")
(define-public python-nox
(package
(name "python-nox")
- (version "2022.11.21")
+ (version "2024.10.09")
(source
(origin
;; No tests in the PyPI tarball.
@@ -2918,25 +2918,8 @@ which make writing and running functional and integration tests easier.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1xfd63h75wiiyri4f7qyvy50f2ny0v4r4wx2h4px9ddbkh2k5g9p"))))
+ (base32 "0gvv6hcwmmmg1sgwar42061ahx5p773d5fzx3c7sq81wh3gp7lqr"))))
(build-system pyproject-build-system)
- (arguments
- (list #:phases
- #~(modify-phases %standard-phases
- ;; NOTE: This manipulation looks not clear as upstream package
- ;; contains "nox/tox_to_nox.jinja2" file which is not copied
- ;; during install phase and causes check and sanity-check
- ;; phases fail due to missing file. Try to find more simple
- ;; solution.
- (add-after 'unpack 'rename-tox-to-nox-jinja2
- (lambda _
- (rename-file "nox/tox_to_nox.jinja2" "nox/tox_to_nox.jinja2.py")))
- (add-after 'install 'rename-tox-to-nox-jinja2-back
- (lambda _
- (let* ((src-file (car (find-files (string-append #$output "/lib")
- "tox_to_nox\\.jinja2\\.py$")))
- (dst-file (string-drop-right src-file 3)))
- (rename-file src-file dst-file)))))))
(propagated-inputs
(list python-argcomplete
python-colorlog
@@ -2944,11 +2927,10 @@ which make writing and running functional and integration tests easier.")
python-py
python-virtualenv))
(native-inputs
- (list python-jinja2
+ (list python-hatchling
+ python-jinja2
python-pytest
- python-tox
- python-setuptools
- python-wheel))
+ python-tox))
(home-page "https://nox.thea.codes/")
(synopsis "Flexible test automation")
(description