aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-01-17 11:06:04 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:25 +0200
commitbb5a44799291275da75d37a91deca93515fc6257 (patch)
treecf95419bd8cbf2da166cdbbeaa2a429e5924e677 /gnu
parentc89d2bcceb9f232cbcabedc745fb721d46e7819c (diff)
downloadguix-bb5a44799291275da75d37a91deca93515fc6257.tar.gz
guix-bb5a44799291275da75d37a91deca93515fc6257.zip
gnu: meson: Update to 1.1.1 and ungraft.
* gnu/packages/build-tools.scm (meson): Update to 1.1.1. [replacement]: Remove. (meson/newer): Remove. (meson-python/newer): Remove. * gnu/packages/pdf.scm (capypdf)[arguments]: Remove #:meson. Change-Id: I77dd9203461e8dd635753ec742bd8046dd63e3f9 * gnu/packages/python-science.scm (python-pandas-2): Use regular meson-python. * gnu/packages/python-xyz.scm (python-contourpy): Same
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/build-tools.scm25
-rw-r--r--gnu/packages/pdf.scm3
-rw-r--r--gnu/packages/python-science.scm2
-rw-r--r--gnu/packages/python-xyz.scm2
4 files changed, 5 insertions, 27 deletions
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index c0cba8076f..d6a788e21c 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -293,8 +293,7 @@ files and generates build instructions for the Ninja build system.")
(define-public meson
(package
(name "meson")
- (replacement meson/newer)
- (version "1.1.0")
+ (version "1.2.1")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/mesonbuild/meson/"
@@ -302,7 +301,7 @@ files and generates build instructions for the Ninja build system.")
version ".tar.gz"))
(sha256
(base32
- "17w2zymmvrffhfpqsaj7qcbjwgv9iaawcpzhz2gnhlvcrm26qqfr"))))
+ "1x9rnrbwvzhnzmz4zqag44w06khks8wckcajxsbr8m4760akmnxi"))))
(build-system python-build-system)
(arguments
(list #:tests? #f ;disabled to avoid extra dependencies
@@ -330,19 +329,6 @@ files}, are written in a custom domain-specific language (@dfn{DSL}) that
resembles Python.")
(license license:asl2.0)))
-(define-public meson/newer
- (package
- (inherit meson)
- (version "1.2.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/mesonbuild/meson/"
- "releases/download/" version "/meson-"
- version ".tar.gz"))
- (sha256
- (base32
- "1x9rnrbwvzhnzmz4zqag44w06khks8wckcajxsbr8m4760akmnxi"))))))
-
(define-public meson-python
(package
(name "meson-python")
@@ -396,13 +382,6 @@ resembles Python.")
(description "Meson-python is a PEP 517 build backend for Meson projects.")
(license license:expat)))
-(define-public meson-python/newer
- (package
- (inherit meson-python)
- (propagated-inputs
- (modify-inputs (package-propagated-inputs meson-python)
- (replace "meson" meson/newer)))))
-
(define-public premake4
(package
(name "premake")
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 3b5e306de1..c68178099b 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -134,8 +134,7 @@
(base32 "0kp1dcww5zl04wnbqbi8vjzpc5qgr8gr8rcx0s6s4xbjnzvqqw8d"))))
(build-system meson-build-system)
(arguments
- (list #:meson meson/newer
- #:configure-flags #~(list "-Dcpp_std=c++23")
+ (list #:configure-flags #~(list "-Dcpp_std=c++23")
#:test-options '(list "plainc")
#:phases
#~(modify-phases %standard-phases
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 4bb8ac342d..7dd426608d 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1081,7 +1081,7 @@ doing practical, real world data analysis in Python.")
(inputs
(list which xclip xsel))
(native-inputs
- (list meson-python/newer
+ (list meson-python
python-beautifulsoup4
python-cython-0.29.35
python-html5lib
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 236e19b59a..d88db26f00 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1296,7 +1296,7 @@ into dataclasses.")
(list python-numpy))
(native-inputs
(list cmake
- meson-python/newer
+ meson-python
pkg-config
pybind11
python-pytest