aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/build-tools.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/build-tools.scm')
-rw-r--r--gnu/packages/build-tools.scm25
1 files changed, 2 insertions, 23 deletions
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index c0cba8076f..d6a788e21c 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -293,8 +293,7 @@ files and generates build instructions for the Ninja build system.")
(define-public meson
(package
(name "meson")
- (replacement meson/newer)
- (version "1.1.0")
+ (version "1.2.1")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/mesonbuild/meson/"
@@ -302,7 +301,7 @@ files and generates build instructions for the Ninja build system.")
version ".tar.gz"))
(sha256
(base32
- "17w2zymmvrffhfpqsaj7qcbjwgv9iaawcpzhz2gnhlvcrm26qqfr"))))
+ "1x9rnrbwvzhnzmz4zqag44w06khks8wckcajxsbr8m4760akmnxi"))))
(build-system python-build-system)
(arguments
(list #:tests? #f ;disabled to avoid extra dependencies
@@ -330,19 +329,6 @@ files}, are written in a custom domain-specific language (@dfn{DSL}) that
resembles Python.")
(license license:asl2.0)))
-(define-public meson/newer
- (package
- (inherit meson)
- (version "1.2.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/mesonbuild/meson/"
- "releases/download/" version "/meson-"
- version ".tar.gz"))
- (sha256
- (base32
- "1x9rnrbwvzhnzmz4zqag44w06khks8wckcajxsbr8m4760akmnxi"))))))
-
(define-public meson-python
(package
(name "meson-python")
@@ -396,13 +382,6 @@ resembles Python.")
(description "Meson-python is a PEP 517 build backend for Meson projects.")
(license license:expat)))
-(define-public meson-python/newer
- (package
- (inherit meson-python)
- (propagated-inputs
- (modify-inputs (package-propagated-inputs meson-python)
- (replace "meson" meson/newer)))))
-
(define-public premake4
(package
(name "premake")