aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 10:46:07 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:03 +0200
commitb53b09a9763c5999575d6c07ac0b03a1fe0d63f4 (patch)
treee1f1356b86c229f448391af19f55a9e3d78f265b /gnu
parent40d9b08a97bb26fad1115e09b494c1ce80c49d5b (diff)
downloadguix-b53b09a9763c5999575d6c07ac0b03a1fe0d63f4.tar.gz
guix-b53b09a9763c5999575d6c07ac0b03a1fe0d63f4.zip
gnu: Add texlive-tikzpeople.
* gnu/packages/tex.scm (texlive-tikzpeople): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c36193c4f1..35562189cc 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5134,6 +5134,29 @@ footer and header area of the current page. They are inspired by the current
page node defined by PGF/TikZ itself.")
(license license:lppl)))
+(define-public texlive-tikzpeople
+ (package
+ (name "texlive-tikzpeople")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/tikzpeople/"
+ "tex/latex/tikzpeople/")
+ (base32
+ "1sgxabjy54zcw0dkb5hgi9d84ilq4ik30xwwd1n8jhhmi4vg2sm7")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/tikzpeople")
+ (synopsis "Draw people-shaped nodes in TikZ")
+ (description
+ "This package provides people-shaped nodes in the style of Microsoft
+Visio clip art, to be used with TikZ. The available, highly customizable,
+node shapes are: alice, bob, bride, builder, businessman, charlie, chef,
+conductor, cowboy, criminal, dave, devil, duck, graduate, groom, guard,
+jester, judge, maninblack, mexican, nun, nurse, physician, pilot, police,
+priest, sailor, santa, surgeon.")
+ (license license:lppl1.3+)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")