aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 10:45:55 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:03 +0200
commit40d9b08a97bb26fad1115e09b494c1ce80c49d5b (patch)
treec4d49c78bbcad2be5799d216953778bf39ee60d4 /gnu
parent4453529a9c12472bf29a25ca1ef7f1491c4c7d05 (diff)
downloadguix-40d9b08a97bb26fad1115e09b494c1ce80c49d5b.tar.gz
guix-40d9b08a97bb26fad1115e09b494c1ce80c49d5b.zip
gnu: Add texlive-tikzpagenodes.
* gnu/packages/tex.scm (texlive-tikzpagenodes): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0b2f34b586..c36193c4f1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5112,6 +5112,28 @@ orbital diagrams.")
"This package allows you to easily display network packets graphically.")
(license license:expat)))
+(define-public texlive-tikzpagenodes
+ (package
+ (name "texlive-tikzpagenodes")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/tikzpagenodes/"
+ "source/latex/tikzpagenodes/"
+ "tex/latex/tikzpagenodes/")
+ (base32
+ "13ddkwm4a1x2b47zqjk2m55y2dwl09rl3s0pm1vmxv7h2sawgqbr")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (native-inputs (list texlive-ydoc))
+ (home-page "https://ctan.org/pkg/tikzpagenodes")
+ (synopsis "Single TikZ node for the whole page")
+ (description
+ "The package provides special PGF/TikZ nodes for the text, marginpar,
+footer and header area of the current page. They are inspired by the current
+page node defined by PGF/TikZ itself.")
+ (license license:lppl)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")