aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-05 21:26:10 -0400
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:05 +0200
commita9cb2e5714b84e205464a8ce2b13b95ffce8d5b3 (patch)
tree5b0be774245008a92faa0fc64e7cfea1936d25a2 /gnu
parentfed026d1de6ef1cc855d3552be0b93740c936204 (diff)
downloadguix-a9cb2e5714b84e205464a8ce2b13b95ffce8d5b3.tar.gz
guix-a9cb2e5714b84e205464a8ce2b13b95ffce8d5b3.zip
gnu: gcc-2.95: Express search paths via (guix search-paths) variables.
* gnu/packages/gcc.scm (gcc-2.95) [native-search-paths]: Express search paths via (guix search-paths) variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gcc.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 30393c09bc..d514e0138d 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -934,12 +934,8 @@ It also includes runtime support libraries for these languages.")
"MAKEINFOFLAGS = --force\n"))))))))
(native-search-paths
;; This package supports nothing but the C language.
- (list (search-path-specification
- (variable "C_INCLUDE_PATH")
- (files '("include")))
- (search-path-specification
- (variable "LIBRARY_PATH")
- (files '("lib")))))))
+ (list $C_INCLUDE_PATH
+ $LIBRARY_PATH))))
(define-public (make-libstdc++ gcc)