aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-12-02 00:09:47 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-12-03 07:49:04 +0100
commita62f59d32dedf7ff11d59daa1251f74c573dd0b5 (patch)
tree5c98e2a45f5db383b475f089e4f2068b8a1281a3 /gnu
parent4c441dbb1466c634ca8f4a864320669e2db73b8d (diff)
downloadguix-a62f59d32dedf7ff11d59daa1251f74c573dd0b5.tar.gz
guix-a62f59d32dedf7ff11d59daa1251f74c573dd0b5.zip
gnu: python-dbusmock: Update to 0.30.0.
* gnu/packages/python-xyz.scm (python-dbusmock): Update to 0.30.0. [#:phases]<patch-paths>: Adjust accordingly. [native-inputs]: Add upower. (python-dbus-minimal): New variable. * gnu/packages/gnome.scm (upower)[native-inputs]: Replace python-dbusmock with python-dbusmock-minimal. * gnu/packages/gtk.scm (at-spi2-core)[native-inputs]: Likewise. (at-spi2-core-with-documentation)[native-inputs]: Adjust accordingly. * gnu/packages/polkit.scm (polkit)[native-inputs]: Replace python-dbusmock with python-dbusmock-minimal. Change-Id: If0cd76da0495d052f94ee5d654436c4d1dd1e2c3
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm2
-rw-r--r--gnu/packages/gtk.scm5
-rw-r--r--gnu/packages/polkit.scm2
-rw-r--r--gnu/packages/python-xyz.scm21
4 files changed, 22 insertions, 8 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c6437ce450..8d2265b10d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5810,7 +5810,7 @@ faster results and to avoid unnecessary server load.")
python
;; For tests.
python-dbus
- python-dbusmock
+ python-dbusmock-minimal
python-packaging
python-pygobject
umockdev
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index b5246c8b3b..761b65fd1f 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -849,7 +849,7 @@ ever use this library.")
gobject-introspection
gsettings-desktop-schemas
pkg-config
- python-dbusmock
+ python-dbusmock-minimal
python-pytest
python-wrapper))
(synopsis "Assistive Technology Service Provider Interface, core components")
@@ -880,7 +880,8 @@ is part of the GNOME accessibility project.")
"/share/doc'\n")))))))))
(native-inputs
(modify-inputs (package-native-inputs at-spi2-core)
- (append gi-docgen python python-sphinx)))
+ (append gi-docgen python python-sphinx)
+ (replace "python-dbusmock" python-dbusmock)))
(properties (alist-delete 'hidden?
(package-properties at-spi2-core)))))
diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index 2f733dd703..337d9b9a73 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -158,7 +158,7 @@
perl
pkg-config
python
- python-dbusmock))
+ python-dbusmock-minimal))
(home-page "https://www.freedesktop.org/wiki/Software/polkit/")
(synopsis "Authorization API for privilege management")
(description "Polkit is an application-level toolkit for defining and
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index db113caae7..44b3f89574 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27374,14 +27374,14 @@ reference implementation of the D-Bus protocol.")
(define-public python-dbusmock
(package
(name "python-dbusmock")
- (version "0.25.0")
+ (version "0.30.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "python-dbusmock" version))
(sha256
(base32
- "1nwl0gzzds2g1w1gfxfzlgrkb5hr1rrdyn619ml25c6b1rjyfk3g"))))
+ "1hanz6x76jq66ypdirga5h15zjs67kwysl6rmsf0i22dbdqrxdfv"))))
(build-system python-build-system)
(arguments
(list #:modules `((guix build python-build-system)
@@ -27392,6 +27392,9 @@ reference implementation of the D-Bus protocol.")
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-paths
(lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "tests/test_api.py"
+ (("/usr/bin/python3")
+ (which "python3")))
(substitute* "tests/test_code.py"
(("/bin/bash")
(which "bash")))
@@ -27418,11 +27421,11 @@ reference implementation of the D-Bus protocol.")
status))
(loop)))))))))))))
(native-inputs
- (list dbus python-pytest which))
+ (list dbus python-pytest upower which))
(inputs
(list dbus))
(propagated-inputs
- (list python-dbus python-pygobject))
+ (list python-dbus-python python-pygobject))
(home-page "https://github.com/martinpitt/python-dbusmock")
(synopsis "Python library for mock D-Bus objects")
(description "python-dbusmock allows for the easy creation of mock objects on
@@ -27432,6 +27435,16 @@ hard (or impossible without root privileges) to set the state of the real
services to what you expect in your tests.")
(license license:lgpl3+)))
+(define-public python-dbusmock-minimal
+ (package
+ (inherit python-dbusmock)
+ (name "python-dbusmock-minimal")
+ (arguments
+ (substitute-keyword-arguments (package-arguments python-dbusmock)
+ ((#:tests? _ #t) #f)))
+ (native-inputs (list which))
+ (properties '((hidden? . #t)))))
+
(define-public python-jsonplus
(package
(name "python-jsonplus")