aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-12-02 00:09:13 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-12-03 07:49:04 +0100
commit4c441dbb1466c634ca8f4a864320669e2db73b8d (patch)
tree141e5e44cc506e8cea9a9d19e57971305db1d2ac /gnu
parent9cc9183472aad3d392e8d98a131c83851fee72c5 (diff)
downloadguix-4c441dbb1466c634ca8f4a864320669e2db73b8d.tar.gz
guix-4c441dbb1466c634ca8f4a864320669e2db73b8d.zip
gnu: Add python-dbus-python.
* gnu/packages/python-xyz.scm (python-dbus-python): New variable. Change-Id: I7d9ba58466e8a07119073209e47814fc9fc573cb
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ec4a611223..db113caae7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -174,6 +174,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages bdw-gc)
+ #:use-module (gnu packages build-tools)
#:use-module (gnu packages check)
#:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
@@ -187,6 +188,7 @@
#:use-module (gnu packages djvu)
#:use-module (gnu packages docker)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages elf)
#:use-module (gnu packages enchant)
#:use-module (gnu packages file)
#:use-module (gnu packages fonts)
@@ -27336,6 +27338,39 @@ structure.")
for YAML and JSON.")
(license license:expat)))
+(define-public python-dbus-python
+ (package
+ (name "python-dbus-python")
+ (version "1.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "dbus-python" version))
+ (sha256
+ (base32 "1y28h90v2ib8zqhs3r2yr7ycg8ccwvw3gqkvadlm12v1129q2rxd"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-requirements
+ (lambda _
+ (substitute* (list "pyproject.toml" "setup.py")
+ (("'(ninja|patchelf)',?") ""))
+ (substitute* "setup.cfg"
+ (("(ninja|patchelf)") "")))))))
+ (inputs (list dbus glib))
+ (propagated-inputs (list python-pygobject))
+ (native-inputs (list pkg-config
+ python-meson-python
+ meson ninja patchelf
+ python-sphinx python-sphinx-rtd-theme
+ python-tappy
+ python-wheel))
+ (home-page "https://dbus.freedesktop.org/doc/dbus-python/")
+ (synopsis "Python bindings for libdbus")
+ (description "This package provides Python bindings to libdbus, the
+reference implementation of the D-Bus protocol.")
+ (license license:expat)))
+
(define-public python-dbusmock
(package
(name "python-dbusmock")