aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-12-01 09:04:21 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-12-01 09:04:21 +0200
commit9c3feb3773ac9af09db3815b6410ce565f9cf70c (patch)
tree50ca8a6473d28dc75eb734aa675fc60405d89373 /gnu
parent10e99250f49d40563619c849b0d4ada31f985991 (diff)
downloadguix-9c3feb3773ac9af09db3815b6410ce565f9cf70c.tar.gz
guix-9c3feb3773ac9af09db3815b6410ce565f9cf70c.zip
gnu: xorgxrdp: Only build with nasm on necessary platforms.
* gnu/packages/rdesktop.scm (xorgxrdp)[native-inputs]: Only include nasm on platforms which need it. Change-Id: I00778cf4b53776754525d42e0586076d4f2be61b
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/rdesktop.scm20
1 files changed, 12 insertions, 8 deletions
diff --git a/gnu/packages/rdesktop.scm b/gnu/packages/rdesktop.scm
index 8024156417..23a950dad3 100644
--- a/gnu/packages/rdesktop.scm
+++ b/gnu/packages/rdesktop.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018, 2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2019 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
@@ -255,13 +255,17 @@ variety of RDP clients:
xdpyinfo
xorg-server
xrdp))
- (native-inputs (list autoconf
- automake
- intltool
- libtool
- nasm
- pkg-config
- pixman))
+ (native-inputs
+ (append
+ (list autoconf
+ automake
+ intltool
+ libtool)
+ (if (target-x86?)
+ (list nasm)
+ '())
+ (list pkg-config
+ pixman)))
(arguments
(list #:configure-flags #~(list "--enable-strict-locations=yes"
(string-append "XRDP_CFLAGS=-I"