aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-11-30 20:05:31 +0300
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-11-30 20:05:31 +0300
commit10e99250f49d40563619c849b0d4ada31f985991 (patch)
tree496363c31da74d8527a71c16c54766f144914734 /gnu
parentf8cb1c0a137c80fc13645dbdd827730e2f04d7dd (diff)
downloadguix-10e99250f49d40563619c849b0d4ada31f985991.tar.gz
guix-10e99250f49d40563619c849b0d4ada31f985991.zip
gnu: go-github-com-arceliar-phony: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-arceliar-phony): Move from here... * gnu/packages/golang-xyz.scm: ...to here. Change-Id: Ia50f331f23326fa8ae6e12b410c12d06cb369bf7
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm23
-rw-r--r--gnu/packages/golang.scm23
2 files changed, 23 insertions, 23 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 0ef4c46d9f..1dc7849edb 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -876,6 +876,29 @@ JSONMarshal/JSONUnmarshal to store/reload the Bloom filter.")
commands.")
(license license:expat)))
+(define-public go-github-com-arceliar-phony
+ (package
+ (name "go-github-com-arceliar-phony")
+ (version "v0.0.0-20220903101357-530938a4b13d")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Arceliar/phony")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ww3issk2jg9nzijmz1xncdhd0mh553nixns34s3yjm4mb8c5s93"))))
+ (arguments
+ '(#:import-path "github.com/Arceliar/phony"))
+ (build-system go-build-system)
+ (home-page "https://github.com/Arceliar/phony")
+ (synopsis "Very minimal actor model library")
+ (description "Phony is a very minimal actor model library for Go,
+inspired by the causal messaging system in the Pony programming language.")
+ (license license:expat)))
+
(define-public go-github-com-armon-go-radix
(package
(name "go-github-com-armon-go-radix")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7f79f511a7..6b78b19cc5 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6523,29 +6523,6 @@ except that it adds convenience functions that use the fmt package to format
error messages.")
(license license:bsd-3)))
-(define-public go-github-com-arceliar-phony
- (package
- (name "go-github-com-arceliar-phony")
- (version "v0.0.0-20220903101357-530938a4b13d")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Arceliar/phony")
- (commit (go-version->git-ref version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1ww3issk2jg9nzijmz1xncdhd0mh553nixns34s3yjm4mb8c5s93"))))
- (arguments
- '(#:import-path "github.com/Arceliar/phony"))
- (build-system go-build-system)
- (home-page "https://github.com/Arceliar/phony")
- (synopsis "Very minimal actor model library")
- (description "Phony is a very minimal actor model library for Go,
-inspired by the causal messaging system in the Pony programming language.")
- (license license:expat)))
-
(define-public go-github-com-gologme-log
;; this is the same as v1.2.0, only the LICENSE file changed
(let ((commit "720ba0b3ccf0a91bc6018c9967a2479f93f56a55"))