aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSimon Tournier <zimon.toutoune@gmail.com>2024-09-10 03:27:11 +0200
committerLudovic Courtès <ludo@gnu.org>2024-12-16 00:19:56 +0100
commit9320d860294fb6af3fe085e2b4c15a95f87b2b94 (patch)
treeb682bb68be8f5f123862b57800ef8b164d00fbb8 /gnu
parent4410b818df884b32e6133cdc776780b5529f8ae1 (diff)
downloadguix-9320d860294fb6af3fe085e2b4c15a95f87b2b94.tar.gz
guix-9320d860294fb6af3fe085e2b4c15a95f87b2b94.zip
gnu: dmd-bootstrap: Move phobos origin from phases to native-inputs.
* gnu/packages/dlang.scm (dmd-bootstrap)[arguments]<phases>: Move phobos origin from here... [native-inputs]: ...to here. Change-Id: I10cb5f628dad2fdbb01df58134996bdcd0b73d62 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/dlang.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/dlang.scm b/gnu/packages/dlang.scm
index 8bf0ee685e..1fd1c8d58c 100644
--- a/gnu/packages/dlang.scm
+++ b/gnu/packages/dlang.scm
@@ -456,15 +456,7 @@ integration tests...\n")
(lambda _
(symlink "." "dmd") ;to please the build system expected layout
(copy-recursively
- #$(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/dlang/phobos")
- (commit (string-append "v" version))))
- (file-name (git-file-name "phobos" version))
- (sha256
- (base32
- "1yw7nb5d78cx9m7sfibv7rfc7wj3w0dw9mfk3d269qpfpnwzs4n9")))
+ #$(this-package-native-input (git-file-name "phobos" version))
"phobos")
(chdir "phobos")))
(add-after 'copy-phobos-source-and-chdir 'adjust-phobos-install-dirs
@@ -519,7 +511,16 @@ integration tests...\n")
"lib")
(("\\.\\./src/(phobos|druntime/import)")
"include/dmd")))))))
- (native-inputs (list gdmd which))
+ (native-inputs (list gdmd which
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dlang/phobos")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "phobos" version))
+ (sha256
+ (base32
+ "1yw7nb5d78cx9m7sfibv7rfc7wj3w0dw9mfk3d269qpfpnwzs4n9")))))
(home-page "https://github.com/dlang/dmd")
(synopsis "Reference D Programming Language compiler")
(description "@acronym{DMD, Digital Mars D compiler} is the reference