aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSimon Tournier <zimon.toutoune@gmail.com>2024-09-10 03:27:10 +0200
committerLudovic Courtès <ludo@gnu.org>2024-12-16 00:19:56 +0100
commit4410b818df884b32e6133cdc776780b5529f8ae1 (patch)
tree533f63425e76ed63b2e45cc65b0831fc19ec50e0 /gnu
parentf8f005815efdf9f0d5d2a5ac30c6fdd19aa22e72 (diff)
downloadguix-4410b818df884b32e6133cdc776780b5529f8ae1.tar.gz
guix-4410b818df884b32e6133cdc776780b5529f8ae1.zip
gnu: gnome-recipes: Move libgd origin from phases to native-inputs.
* gnu/packages/dlang.scm (gnome-recipes)[arguments]<phases>: Move libgd origin from here... [native-inputs]: ...to here. Change-Id: Ic1775a66608e114b5b31058386c8b739c155b7a5 Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b4016a2fbc..e020632078 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -799,15 +799,7 @@ patterns.")
(add-after 'unpack 'unpack-libgd
(lambda _
(copy-recursively
- #$(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.gnome.org/GNOME/libgd")
- (commit "c7c7ff4e05d3fe82854219091cf116cce6b19de0")))
- (file-name (git-file-name "libgd" version))
- (sha256
- (base32
- "16yld0ap7qj1n96h4f2sqkjmibg7xx5xwkqxdfzam2nmyfdlrrrs")))
+ #$(this-package-native-input "libgd-checkout")
"subprojects/libgd"))))))
(inputs (list glib
gnome-autoar
@@ -821,6 +813,15 @@ patterns.")
(native-inputs (list desktop-file-utils ;for update-desktop-database
gettext-minimal
`(,glib "bin")
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.gnome.org/GNOME/libgd")
+ (commit "c7c7ff4e05d3fe82854219091cf116cce6b19de0")))
+ (file-name "libgd-checkout")
+ (sha256
+ (base32
+ "16yld0ap7qj1n96h4f2sqkjmibg7xx5xwkqxdfzam2nmyfdlrrrs")))
itstool
pkg-config
python))