aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-08-26 00:23:37 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-27 00:33:34 +0100
commit8625e4200dec9cd224f72c665ead3651ef020753 (patch)
treef5e4d8f633af148962d385872bcafe833d5237e4 /gnu
parent23e271ff30d520f526091d7e0624bb6dbd151c55 (diff)
downloadguix-8625e4200dec9cd224f72c665ead3651ef020753.tar.gz
guix-8625e4200dec9cd224f72c665ead3651ef020753.zip
gnu: Add go-github-com-libp2p-go-cidranger.
* gnu/packages/golang-web.scm (go-github-com-libp2p-go-cidranger): New variable. Change-Id: I4e21f87c7b77ae8a5f7fa2e098330ec15bff079e Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 8280a131fb..c663a9c5e5 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2661,6 +2661,38 @@ router.")
@acronym{Simple Service Discovery Protocol, SSDP}} library for Golang.")
(license license:expat)))
+(define-public go-github-com-libp2p-go-cidranger
+ (package
+ (name "go-github-com-libp2p-go-cidranger")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libp2p/go-cidranger")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05hzlk5hx7qna5znr3q1crr0qb7h8yrv1v96pj015dh0kbdkdaba"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/libp2p/go-cidranger"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-ipfs-go-detect-race))
+ (home-page "https://github.com/libp2p/go-cidranger")
+ (synopsis "Fast IP to CIDR lookup in Golang")
+ (description
+ "Fast IP to @url{https://en.wikipedia.org/wiki/Classless_Inter-Domain_Routing,
+CIDR} block(s) lookup using trie in Golang, inspired by
+@url{https://vincent.bernat.im/en/blog/2017-ipv4-route-lookup-linux, IPv4
+route lookup Linux}. Possible use cases include detecting if a IP address is
+from published cloud provider CIDR blocks (e.g. 52.95.110.1 is contained in
+published AWS Route53 CIDR 52.95.110.0/24), IP routing rules, etc.")
+ (license license:expat)))
+
(define-public go-github-com-libp2p-go-flow-metrics
(package
(name "go-github-com-libp2p-go-flow-metrics")