aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-08-26 00:23:36 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-27 00:33:34 +0100
commit23e271ff30d520f526091d7e0624bb6dbd151c55 (patch)
tree810bdb93a163981c523f6f4f82441d2e894ace37 /gnu
parent346fb50dd2a20f9fc19082ca4a31fc7631b63dc7 (diff)
downloadguix-23e271ff30d520f526091d7e0624bb6dbd151c55.tar.gz
guix-23e271ff30d520f526091d7e0624bb6dbd151c55.zip
gnu: Add go-github-com-libp2p-go-yamux-v4.
* gnu/packages/golang-web.scm (go-github-com-libp2p-go-yamux-v4): New variable. Change-Id: I2c0303c8253bbadde69aee0f15a83fe504fd7b12 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index dd156aac70..8280a131fb 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2818,6 +2818,36 @@ NAT hole-punching, which requires a process to both @code{Listen} and
around enabling this behaviour on various operating systems.")
(license license:isc)))
+(define-public go-github-com-libp2p-go-yamux-v4
+ (package
+ (name "go-github-com-libp2p-go-yamux-v4")
+ (version "4.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libp2p/go-yamux")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13px8fcjjp02cricabbf3x410jkr8sb6r369nqq1zrgr7v90s22j"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/libp2p/go-yamux/v4"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-libp2p-go-buffer-pool))
+ (home-page "https://github.com/libp2p/go-yamux")
+ (synopsis "Reuse TCP/UDP ports in Golang")
+ (description
+ "Yamux (Yet another Multiplexer) is a multiplexing library for Golang.
+It relies on an underlying connection to provide reliability and ordering,
+such as TCP or Unix domain sockets, and provides stream-oriented multiplexing.
+It is inspired by SPDY but is not interoperable with it.")
+ (license (list license:mpl2.0 license:bsd-3))))
+
(define-public go-github-com-mailru-easyjson
(package
(name "go-github-com-mailru-easyjson")