aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-16 23:45:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:17 +0200
commit7f19818e4e90a1079f29cd577107bf5431e9326a (patch)
tree1c4abe37241dc2f079c0a031e1c6630ce4b8efcd /gnu
parentb5279feb7e9e15f98ca798d85c39df4d8f7261be (diff)
downloadguix-7f19818e4e90a1079f29cd577107bf5431e9326a.tar.gz
guix-7f19818e4e90a1079f29cd577107bf5431e9326a.zip
gnu: texlive-hardwrap: Refresh package definition.
* gnu/packages/tex.scm (texlive-hardwrap): Remove SIMPLE-TEXLIVE-PACKAGE call. [propagated-inputs]: Add TEXLIVE-IFPLATFORM, TEXLIVE-IFTEX, TEXLIVE-PDFTEXCMDS.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm35
1 files changed, 21 insertions, 14 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ef2fef4def..9e90bb0ca1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1953,22 +1953,29 @@ rest of the mathematics produced by (AmS-)LaTeX.")
(define-public texlive-hardwrap
(package
- (inherit (simple-texlive-package
- "texlive-hardwrap"
- (list "doc/latex/hardwrap/"
- "tex/latex/hardwrap/"
- "source/latex/hardwrap/")
- (base32
- "0ql3xml1ccll44q945n7w72p6d51y5wcrkawi7cg621gy5d6wzx5")
- #:trivial? #t))
- (home-page "https://ctan.org/macros/latex/contrib/hardwrap")
+ (name "texlive-hardwrap")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/hardwrap/" "source/latex/hardwrap/"
+ "tex/latex/hardwrap/")
+ (base32
+ "0ql3xml1ccll44q945n7w72p6d51y5wcrkawi7cg621gy5d6wzx5")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-ifplatform
+ texlive-iftex
+ texlive-pdftexcmds))
+ (home-page "https://ctan.org/pkg/hardwrap")
(synopsis "Hard wrap text to a certain character length")
(description
- "The package facilitates wrapping text to a specific character width, breaking
-lines by words rather than, as done by TeX, by characters. The primary use for
-these facilities is to aid the generation of messages sent to the log file or
-console output to display messages to the user. Package authors may also find
-this useful when writing out arbitrary text to an external file.")
+ "The package facilitates wrapping text to a specific character width,
+breaking lines by words rather than, as done by TeX, by characters. The
+primary use for these facilities is to aid the generation of messages sent to
+the log file or console output to display messages to the user. Package
+authors may also find this useful when writing out arbitrary text to an
+external file.")
(license license:lppl1.3+)))
(define-public texlive-helvetic