aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-16 23:40:24 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:17 +0200
commitb5279feb7e9e15f98ca798d85c39df4d8f7261be (patch)
treec0da84eac07113f585f7a96b8f1a6d3e02952f2d /gnu
parent6092f24536962ef8e66f7942c16ae5fb3983a2e4 (diff)
downloadguix-b5279feb7e9e15f98ca798d85c39df4d8f7261be.tar.gz
guix-b5279feb7e9e15f98ca798d85c39df4d8f7261be.zip
gnu: texlive-helvetic: Refresh package definition.
* gnu/packages/tex.scm (texlive-helvetic): Remove SIMPLE-TEXLIVE-PACKAGE call.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm41
1 files changed, 22 insertions, 19 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7a7bc79038..ef2fef4def 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1973,27 +1973,30 @@ this useful when writing out arbitrary text to an external file.")
(define-public texlive-helvetic
(package
- (inherit (simple-texlive-package
- "texlive-helvetic"
- (list "/dvips/helvetic/"
- "/fonts/afm/adobe/helvetic/"
- "/fonts/afm/urw/helvetic/"
- "/fonts/map/dvips/helvetic/"
- "/fonts/tfm/adobe/helvetic/"
- "/fonts/tfm/monotype/helvetic/"
- "/fonts/tfm/urw35vf/helvetic/"
- "/fonts/type1/urw/helvetic/"
- "/fonts/vf/adobe/helvetic/"
- "/fonts/vf/monotype/helvetic/"
- "/fonts/vf/urw35vf/helvetic/"
- "/tex/latex/helvetic/")
- (base32
- "0c3f1ly7y6404z0akbfbbfql13sz717v0n0g69qjpr69hi4n0nsl")
- #:trivial? #t))
+ (name "texlive-helvetic")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "dvips/helvetic/"
+ "fonts/afm/adobe/helvetic/"
+ "fonts/afm/urw/helvetic/"
+ "fonts/map/dvips/helvetic/"
+ "fonts/tfm/adobe/helvetic/"
+ "fonts/tfm/monotype/helvetic/"
+ "fonts/tfm/urw35vf/helvetic/"
+ "fonts/type1/urw/helvetic/"
+ "fonts/vf/adobe/helvetic/"
+ "fonts/vf/monotype/helvetic/"
+ "fonts/vf/urw35vf/helvetic/"
+ "tex/latex/helvetic/")
+ (base32
+ "0c3f1ly7y6404z0akbfbbfql13sz717v0n0g69qjpr69hi4n0nsl")))
+ (build-system texlive-build-system)
(home-page "https://ctan.org/pkg/urw-base35")
(synopsis "URW Base 35 font pack for LaTeX")
- (description "This package provides a drop-in replacements for the Helvetica
-font from Adobe's basic set.")
+ (description
+ "This package provides a drop-in replacements for the Helvetica font from
+Adobe's basic set.")
;; No license version specified.
(license license:gpl3+)))