aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAdam Kandur <rndd@tuta.io>2021-08-29 19:52:55 +0300
committerLudovic Courtès <ludo@gnu.org>2021-09-24 14:11:11 +0200
commit73e44626371446a98f7d3e962f074db702e30fed (patch)
treebf1d4623b5f24aa0425e479d8bd401cb6c21fcce /gnu
parentd055e1f4aa8a31e4ccd94273f910544ecf4c6d16 (diff)
downloadguix-73e44626371446a98f7d3e962f074db702e30fed.tar.gz
guix-73e44626371446a98f7d3e962f074db702e30fed.zip
gnu: Add go-github-com-DHowett-go-plist.
* gnu/packages/golang.scm (go-github-com-DHowett-go-plist): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f02d0aa9df..a96f743f68 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1191,6 +1191,35 @@ standardized in RFC 7539.")
(description "Set is the set collection for the Go language.")
(license license:expat)))
+(define-public go-github-com-dhowett-go-plist
+ (let ((commit "1454fab16a0642638feb0ae98c41f79eccb2a20a")
+ (revision "1"))
+ (package
+ (name "go-github-com-dhowett-go-plist")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/DHowett/go-plist")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "01c9wmhny2rxywcjipq1xa0xw4qm7yd001239grwxcja3b4n45v8"))))
+ (build-system go-build-system)
+ (arguments `(#:import-path "howett.net/plist"))
+ (inputs
+ `(("go-github.com-jessevdk-go-flags" ,go-github.com-jessevdk-go-flags)
+ ("go-github-com-kr-pretty" ,go-github-com-kr-pretty)
+ ("go-gopkg-in-check-v1" ,go-gopkg-in-check-v1)
+ ("go-gopkg-in-yaml-v2" ,go-gopkg-in-yaml-v2)))
+ (home-page "https://github.com/DHowett/go-plist")
+ (synopsis "Apple property list transcoder")
+ (description "This list transcoder supports encoding/decoding property
+lists (Apple XML, Apple Binary, OpenStep, and GNUStep) from/to arbitrary Go
+types.")
+ (license license:giftware))))
+
(define-public go-github-com-blanu-dust
(package
(name "go-github-com-blanu-dust")
-5.1): Rename to ... (libstdc++-doc-5): ... this, and use gcc-5. * gnu/packages/commencement.scm (gcc-toolchain-5.1): Rename to ... (gcc-toolchain-5): ... this, and use gcc-5. * build-aux/hydra/gnu-system.scm (%core-packages): Use gcc-5. Mark H Weaver 2015-07-19Merge branch 'master' into core-updatesMark H Weaver 2015-07-19gnu: Add gnu-c-manual....* gnu/packages/gcc.scm (gnu-c-manual): New variable. Ludovic Courtès 2015-07-15Merge branch 'master' into core-updatesMark H Weaver 2015-07-12gnu: Add 'libstdc++-doc'....* gnu/packages/gcc.scm (make-libstdc++-doc): New procedure. (libstdc++-doc-4.9, libstdc++-doc-5.1): New variables. Ludovic Courtès 2015-07-11gnu: Require NEON on armhf....* gnu/packages/gcc.scm (gcc-configure-flags-for-triplet): On armhf, include --with-fpu=neon. * doc/guix.texi (GNU Distribution): Document that our armhf port requires NEON. Mark H Weaver 2015-07-10gnu: gcc-4.9: Update to 4.9.3....* gnu/packages/gcc.scm (gcc-4.9): Update to 4.9.3. Remove "gcc-arm-link-spec-fix.patch" from patches. Mark H Weaver 2015-06-29gnu: Add libiberty....* gnu/packages/gcc.scm (make-libiberty, libiberty): New variables. Ricardo Wurmus 2015-06-29gnu: gcc-4.8: Update to 4.8.5....* gnu/packages/gcc.scm (gcc-4.8): Update to 4.8.5. Ludovic Courtès 2015-06-25gnu: Add default GCC and default gfortran....* gnu/packages/gcc.scm (gcc): New variable. * gnu/packages/gcc.scm (gfortran): New variable. Ricardo Wurmus 2015-06-24gnu: Add gfortran 4.9....* gnu/packages/gcc.scm (gfortran-4.9): New variable. Ricardo Wurmus 2015-06-21Merge branch 'master' into core-updatesMark H Weaver 2015-06-19gnu: Add libstdc++ as a standalone package....* gnu/packages/gcc.scm (make-libstdc++): New procedure. (libstdc++-4.9): New variable. * gnu/packages/commencement.scm (libstdc++): Add TODO comment. Ludovic Courtès 2015-06-14gnu: gcc: Build libsanitizer's bundled libbacktrace without -Werror....* gnu/packages/gcc.scm (gcc-4.7)[arguments]: Also patch libsanitizer/libbacktrace/Makefile.in. Ludovic Courtès 2015-06-10Merge branch 'master' into core-updatesMark H Weaver 2015-06-09gnu: gcc: Build libbacktrace without -Werror....* gnu/packages/gcc.scm (gcc-4.7)[arguments] <pre-configure>: Remove -Werror from libbacktrace/configure. Ludovic Courtès 2015-06-09gnu: gcc: Add "debug" output, debugging symbols of libraries....* gnu/packages/gcc.scm (gcc-4.7)[install-target]: Remove. [outputs]: Add "debug". [arguments]: Remove #:strip-binaries?. Remove 'install' phase. Ludovic Courtès 2015-06-09gnu: gcc: Do not add -rpath=LIBDIR/lib64 to the "lib" spec....* gnu/packages/gcc.scm (gcc-4.7): Remove unneeded LIBDIR/lib64 from GNU_USER_TARGET_LIB_SPEC. Ludovic Courtès 2015-06-04gnu: gcc: Move patch upstream status in the patch itself....* gnu/packages/patches/gcc-arm-link-spec-fix.patch: Add bug and patch URLs. * gnu/packages/gcc.scm (gcc-4.8): Remove them. Ludovic Courtès 2015-05-08gnu: gcj: Add $libdir to RUNPATH....* gnu/packages/gcc.scm (gcj)[arguments]: Add build phase to add library output directory to RUNPATH. Ricardo Wurmus 2015-05-04gnu: gcc-5.1: Add specific libvtv patch....* gnu/packages/patches/gcc-5.0-libvtv-runpath.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/gcc.scm (gcc-5.1)[source]: Use it. Ludovic Courtès 2015-05-02gnu: gcj: Remove broken symlink and conflicting files....* gnu/packages/gcc.scm (gcj)[arguments]: Add a build phase to remove a broken symlink and generic stump binaries. Ricardo Wurmus 2015-04-30gnu: gcc: Add link to upstream bug report....* gnu/packages/gcc.scm (gcc-4.8): Add link to bug report in comment. Ludovic Courtès 2015-04-30gnu: gcc: Add $libdir to the RUNPATH of libvtv.so....* gnu/packages/gcc.scm (gcc-4.9): Inherit from GCC-4.8. [source]: Add 'gcc-libvtv-runpath.patch'. (gcc-5.1): Inherit from GCC-4.9. [source]: Use patches from GCC-4.9. * gnu/packages/patches/gcc-libvtv-runpath.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. Ludovic Courtès 2015-04-26Merge branch 'master' into core-updates.Andreas Enge 2015-04-23gnu: Add gcc-5.1.0 and gcc-toolchain-5.1.0....* gnu/packages/gcc.scm (gcc-5.1): New variable. * gnu/packages/commencement.scm (gcc-toolchain-5.1): New variable. Mark H Weaver 2015-04-23gnu: gcc: Do not always disable RUNPATH validation....* gnu/packages/gcc.scm (gcc-4.7)[arguments]: Remove explicit #:validate-runpath? #f. * gnu/packages/commencement.scm (gcc-boot0)[arguments]: Remove case for #:validate-runpath?. (gcc-final)[arguments]: Add literal #:validate-runpath? #f. * gnu/packages/cross-base.scm (cross-gcc-arguments): Remove case for #:validate-runpath?. Ludovic Courtès 2015-04-23gnu: gcc: Add a RUNPATH to libstdc++.so so that it finds libgcc_s.so....Fixes <http://bugs.gnu.org/20358>. Reported by 宋文武 <iyzsong@gmail.com>. * gnu/packages/gcc.scm (gcc-4.7)[arguments]: Add 'substitute*' form for "libstdc++-v3/src/Makefile.in". Ludovic Courtès 2015-04-20gnu: Remove all #:select from (gnu packages ...) modules....This works around Guile bug <http://bugs.gnu.org/15540>. Reported by Andreas Enge <andreas@enge.fr>. * gnu/packages/engineering.scm: Don't #:select from (gnu packages ...). * gnu/packages/gcc.scm: Likewise. * gnu/packages/package-management.scm: Likewise. * gnu/packages/photo.scm: Likewise. * gnu/packages/pulseaudio.scm: Likewise. * gnu/packages/moe.scm: Likewise, and #:select from (guix licenses) instead. Ludovic Courtès 2015-04-09gnu: gcc: Do not pass -dynamic-linker to linker when !shared on arm....Fixes <http://bugs.gnu.org/20102>. * gnu/packages/patches/gcc-arm-link-spec-fix.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/gcc.scm (gcc-4.8, gcc-4.9): Add patch. * gnu/packages/cross-base.scm (cross-gcc): Preserve patches from gcc-4.8. Co-Authored-By: Ludovic Courtès <ludo@gnu.org> Mark H Weaver 2015-04-07gnu: gcc: Disable RUNPATH validation for native builds....* gnu/packages/gcc.scm (gcc-4.7)[arguments]: Pass #:validate-runpath? #f. * gnu/packages/commencement.scm (gcc-boot0)[arguments]: Override #:validate-runpath? with 'substitute-keyword-arguments'. (gcc-final)[arguments]: Likewise. * gnu/packages/cross-base.scm (cross-gcc-arguments): Likewise. Ludovic Courtès 2015-04-02gnu: gcc: Fix libgcc_s directory in RUNPATH for cross-compiled binaries....* gnu/packages/gcc.scm (gcc-4.7): Add 'libdir' procedure. Use it to determine the right libdir, including when cross-compiling. This fixes a bug whereby the RUNPATH of cross-compiled binaries would be set to $crossgcc/lib instead of $crossgcc/$triplet/lib. See <http://hydra.gnu.org/build/354389/nixlog/1/raw> for an example. Ludovic Courtès 2015-03-08gnu: gcj: Use a versioned URL for 'javac.in'....* gnu/packages/gcc.scm (javac.in): Use a ViewVC URL that specifies the CVS revision. Ludovic Courtès 2015-03-07gnu: gcj: Move javac.in from a file in the distribution to an origin....* gnu/packages/javac.in: Delete file. * gnu-system.am (MISC_DISTRO_FILES): Delete. * gnu/packages/gcc.scm (javac.in): New variable. (gcj-4.8): Use it as an input. Andreas Enge 2015-03-07gnu: gcc: Add copyright line.Andreas Enge 2015-01-27gnu: Add GCJ...* gnu/packages/gcc.scm (gcj-4.8, ecj-bootstrap-4.8): New variables. * gnu/packages/javac.in: New file. * gnu-system.am (MISC_DISTRO_FILES): Add it. * Makefile.am (nobase_dist_guilemodule_DATA): Add MISC_DISTRO_FILES. Ricardo Wurmus