aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-06-21 14:30:22 -0400
committerMark H Weaver <mhw@netris.org>2015-06-21 14:30:22 -0400
commitbf76d98789a0fc6303c303beddbc1ed609f2a6ea (patch)
tree1df8db2fa06f6826a1c7a1cb1faa253df704834e /gnu/packages/gcc.scm
parentfc9ff915b3cfcb494dbb5c8ab767972352fa31da (diff)
parent12b04cbee6b9c725db8a5c898b597de8e667bef0 (diff)
downloadguix-bf76d98789a0fc6303c303beddbc1ed609f2a6ea.tar.gz
guix-bf76d98789a0fc6303c303beddbc1ed609f2a6ea.zip
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index beb007e95b..c370fe8212 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -345,6 +345,32 @@ Go. It also includes runtime support libraries for these languages.")
'("gcc-arm-link-spec-fix.patch"
"gcc-5.0-libvtv-runpath.patch")))))))
+(define-public (make-libstdc++ gcc)
+ "Return a libstdc++ package based on GCC. The primary use case is when
+using compilers other than GCC."
+ (package
+ (inherit gcc)
+ (name "libstdc++")
+ (arguments
+ `(#:out-of-source? #t
+ #:phases (alist-cons-before
+ 'configure 'chdir
+ (lambda _
+ (chdir "libstdc++-v3"))
+ %standard-phases)
+ #:configure-flags `("--disable-libstdcxx-pch"
+ ,(string-append "--with-gxx-include-dir="
+ (assoc-ref %outputs "out")
+ "/include"))))
+ (outputs '("out" "debug"))
+ (inputs '())
+ (native-inputs '())
+ (propagated-inputs '())
+ (synopsis "GNU C++ standard library")))
+
+(define-public libstdc++-4.9
+ (make-libstdc++ gcc-4.9))
+
(define* (custom-gcc gcc name languages #:key (separate-lib-output? #t))
"Return a custom version of GCC that supports LANGUAGES."
(package (inherit gcc)