aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-11-06 12:42:39 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-11-06 12:49:40 +0200
commitff799a1a956a3cf636774701f632c779d08589bf (patch)
tree8d6440e13570c307f7bdece97024258c95b93813 /gnu
parente6ec657c497cdfe9130b7bf5bdfb717a823bf02b (diff)
downloadguix-ff799a1a956a3cf636774701f632c779d08589bf.tar.gz
guix-ff799a1a956a3cf636774701f632c779d08589bf.zip
gnu: tinyxml: Honor the #:tests? flag.
* gnu/packages/xml.scm (tinyxml)[arguments]: Adjust the custom 'check phase to honor the #:tests? flag. Change-Id: Id085358cc07572be3bcee887c825c826f1b00f58
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xml.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 4a3936b66d..575cc016bb 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1283,7 +1283,9 @@ UTF-8 and UTF-16 encoding.")
"tinyxmlparser.cpp" "tinystr.cpp"
"-o" "libtinyxml.so")))
(replace 'check
- (lambda _ (invoke "./xmltest")))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "./xmltest"))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))