aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-10 14:38:08 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:09 +0000
commit62f52b0e7138099c35b5f97e3ed548b9d237efc2 (patch)
tree306f1aa9e16e1bad082e1a4597012c8d7aab74c1 /gnu
parentcf0e5934d2209490b97500dcdbf2ba2196d50462 (diff)
downloadguix-62f52b0e7138099c35b5f97e3ed548b9d237efc2.tar.gz
guix-62f52b0e7138099c35b5f97e3ed548b9d237efc2.zip
gnu: python-fast-histogram: Adjust inputs.
* gnu/packages/python-science.scm (python-fast-histogram) [native-inputs]: Add python-setuptools and python-wheel. Change-Id: I53e2ce8019c421894e50138099539021a91f7c24
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-science.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 8fec109a71..495836c4a8 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1748,11 +1748,14 @@ higher scores.")
(add-before 'check 'build-extensions
(lambda _
(invoke "python" "setup.py" "build_ext" "--inplace"))))))
- (propagated-inputs (list python-numpy))
(native-inputs
(list python-hypothesis
python-pytest
- python-setuptools-scm))
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
+ (propagated-inputs
+ (list python-numpy))
(home-page "https://github.com/astrofrog/fast-histogram")
(synopsis "Fast simple 1D and 2D histograms")
(description