aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-11-12 14:33:05 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-11-20 19:18:26 +0800
commit5f069f6c61b0c8d8bec8f1138281fc9066bc000b (patch)
treea2b50f743b152dd0163ed0de434348a3dd6b3304 /gnu
parent561deac3c0209d15455230ecc9496c800d1ecc55 (diff)
downloadguix-5f069f6c61b0c8d8bec8f1138281fc9066bc000b.tar.gz
guix-5f069f6c61b0c8d8bec8f1138281fc9066bc000b.zip
gnu: libseat, seatd: Update to 0.9.1.
* gnu/packages/admin.scm (libseat): Update to 0.9.1. [arguments]: Use G-expressions. [native-inputs]: Remove label. [propagated-inputs]: Remove label. (seatd): [arguments]: Use G-expressions. [native-inputs]: Remove label. Change-Id: I53ebe502ad80bc892e995749aae3387c42a79bad
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm30
1 files changed, 15 insertions, 15 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 9c765b51a9..c0f12e308e 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -5763,7 +5763,7 @@ on a GUI toolkit.")
(define-public libseat
(package
(name "libseat")
- (version "0.8.0")
+ (version "0.9.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -5772,15 +5772,15 @@ on a GUI toolkit.")
(file-name (git-file-name name version))
(sha256
(base32
- "02wzrgp8di6hqmicnm2fim6jnvbn62wy248ikvdvrhiywrb7i931"))))
+ "1q1ih1f9v5240nlas1gz44giwq4k88p3yikfq7w0a4sw58yr6pz8"))))
(build-system meson-build-system)
(arguments
- `(#:configure-flags '("-Dlibseat-logind=elogind"
- "-Dserver=disabled")))
+ (list #:configure-flags #~(list "-Dlibseat-logind=elogind"
+ "-Dserver=disabled")))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(propagated-inputs
- `(("elogind" ,elogind)))
+ (list elogind))
(home-page "https://sr.ht/~kennylevinsen/seatd")
(synopsis "Seat management library")
(description
@@ -5793,16 +5793,16 @@ allows applications to use whatever seat management is available.")
(inherit libseat)
(name "seatd")
(arguments
- `(#:configure-flags '("-Dlibseat-logind=elogind")
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'remove-libs
- (lambda* (#:key outputs #:allow-other-keys)
- (with-directory-excursion (assoc-ref outputs "out")
- (for-each delete-file-recursively '("lib" "include"))))))))
+ (list #:configure-flags #~(list "-Dlibseat-logind=elogind")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'remove-libs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (with-directory-excursion (assoc-ref outputs "out")
+ (for-each delete-file-recursively '("lib" "include"))))))))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("scdoc" ,scdoc)))
+ (list pkg-config
+ scdoc))
(inputs '())
(synopsis "Seat management daemon")
(description