aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-11 22:04:06 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:10 +0000
commit5cdd45f0f155787b13eccc63c60f71ee123ff58b (patch)
tree45468527f0adc06bcc83cd1d0b397f61720ae836 /gnu
parent2b13ecf29052cff205a56cb519befddd4905e7f9 (diff)
downloadguix-5cdd45f0f155787b13eccc63c60f71ee123ff58b.tar.gz
guix-5cdd45f0f155787b13eccc63c60f71ee123ff58b.zip
gnu: python-pytest-forked: Disable tests.
* gnu/packages/check.scm (python-pytest-forked): Disable tests. Tests depends on python-py which is in maintenance mode and should not be used in projects. Change-Id: I6f1df45b121dc21f3af09dd9476c34d31c09a06e
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/check.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index eae0de3a58..5fc9767df1 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2128,7 +2128,9 @@ timeout has been exceeded.")
"1y93q914gwf0nshql1qix6sj826q163b04vw17zmwhsnbv00c2d3"))))
(build-system pyproject-build-system)
(arguments
- (list #:phases
+ ;; See <https://github.com/pytest-dev/pytest-forked/issues/88>.
+ (list #:tests? #f
+ #:phases
#~(modify-phases %standard-phases
(add-before 'build 'pretend-version
;; The version string is usually derived via setuptools-scm,