aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-17 11:38:01 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:10 +0000
commit2b13ecf29052cff205a56cb519befddd4905e7f9 (patch)
treef85824dce451d0e45b369ad759b2045bc32b019a /gnu
parent32c04ab30ebf3953529eb19d19f625af10664635 (diff)
downloadguix-2b13ecf29052cff205a56cb519befddd4905e7f9.tar.gz
guix-2b13ecf29052cff205a56cb519befddd4905e7f9.zip
gnu: python-pytest-timeout: Update to 2.3.1.
* gnu/packages/check.scm (python-pytest-timeout): Update to 2.3.1. [build-system]: Swap pyproject-build-system. [arguments]<phases>: Use default 'check phase. [propagated-inputs]: Remove python-pytest-cov. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: I59da6f90ef8839bce239b6a3199dc58d4a901e81
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/check.scm21
1 files changed, 8 insertions, 13 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 3fc3f1de5b..eae0de3a58 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2090,26 +2090,21 @@ result back.")
(define-public python-pytest-timeout
(package
(name "python-pytest-timeout")
- (version "2.1.0")
+ (version "2.3.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-timeout" version))
(sha256
(base32
- "1nf339zg6qam3681f72j9c8fbqk8qcilna92psmzh4n60isa0z60"))))
- (build-system python-build-system)
- (arguments
- '(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- ;; Make the installed plugin discoverable by Pytest.
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv"))))))
- (propagated-inputs
- (list python-pytest python-pytest-cov))
+ "1nb5a6xf2p9zbcasy8136nbxpm1raag5n0q1rbdcnvjw28lpff8j"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-pexpect))
+ (list python-pexpect
+ python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-pytest))
(home-page "https://github.com/pytest-dev/pytest-timeout")
(synopsis "Plugin for py.test to abort hanging tests")
(description