aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-12-16 16:30:36 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:20 +0100
commit23aa7ba596f947f859d9a3cdbf3bb7f9a6c9fd28 (patch)
tree9b259dbb8aa16d64591ebcc866bb3e75127fa45c /gnu
parente4c6491fd54c156687bdccf2d14ef7ef72777d72 (diff)
downloadguix-23aa7ba596f947f859d9a3cdbf3bb7f9a6c9fd28.tar.gz
guix-23aa7ba596f947f859d9a3cdbf3bb7f9a6c9fd28.zip
gnu: python-pytest-qt: Update to 4.4.0.
* gnu/packages/python-check.scm (python-pytest-qt): Update to 4.4.0. [build-system]: Use pyproject-build-system. [arguments]: Remove #:test-target; remove trailing #T from build phase. [propagated-inputs]: Add python-pluggy and python-pytest. [native-inputs]: Remove python-pytest and python-pytest-runner; add python-pre-commit, python-setuptools, python-tox, and python-wheel. Change-Id: Ibeca84e841264eb81cc7ba48b5e815d0b837cb4d
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-check.scm21
1 files changed, 12 insertions, 9 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 2fae13aa04..f70028c65f 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -2063,19 +2063,22 @@ libraries.")
(uri (pypi-uri "pytest-qt" version))
(sha256
(base32 "0i38qp2rqb44grbk9rn7zr5ffjvdlcl6k380759ji920m51632bn"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- `(#:test-target "pytest"
- #:phases
- (modify-phases %standard-phases
+ (list
+ ;;#:test-target "pytest"
+ #:phases
+ '(modify-phases %standard-phases
(add-before 'check 'set-qpa
- (lambda _
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
+ (lambda _ (setenv "QT_QPA_PLATFORM" "offscreen"))))))
(propagated-inputs
- (list python-pyqt))
+ (list python-pluggy python-pyqt python-pytest))
(native-inputs
- (list python-pytest python-pytest-runner python-setuptools-scm))
+ (list python-pre-commit
+ python-setuptools
+ python-setuptools-scm
+ python-tox
+ python-wheel))
(home-page "https://github.com/pytest-dev/pytest-qt")
(synopsis "Pytest support for PyQt and PySide applications")
(description